Missing Hard Drive

  Photographica1 18:43 07 Apr 2007
Locked

Hi all,

I have just upgraded my C: drive to a larger one using Acronis Easy Migrate. The migration appears to have work fine apart from this problem.
When I cloned the C:drive, I temporarily removed the D: drive to us the IDE cable position for the new C: Drive.

When cloning was completed, I removed the old C: drive (master), switched the new C: drive (master and replaced the untouched D: drive (Slave).

Windows explorer no longer shows my d: drive! the BIOS recognises it, and system devices shows it as working fine. Even reports back the correct capacity etc.

I uninstalled it in devices and repbooted - windows reported new hardware found, installed it and it still does not show in explorer. I need to get at it because my data is on there. Please help

Have you looked at start/right click on my computer/manage/select disk management and is the drive letter shown? right click gives the option to set drive letter.

  Photographica1 22:32 07 Apr 2007

Hi,

I did a full reformat and reinstall of windows - when it restarted, D: was back - right where I left it, Thank god.

  woodchip 22:39 07 Apr 2007

Use the link in the Message on this page for TestDisk. click here

  woodchip 22:40 07 Apr 2007

PS it worked for me when I lost my D:\Partition after a MS update

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?