missing dos files

  stephjh 22:43 05 Mar 2004

Following a failed hard drive I have reinstalled Windows 98 SE on a new one but I'm having a few problems. The following error messages appear when booting:
Cannot find a device file that may be needed to run windows or a windows application. The windows registry or SYSTEM.INI file refers to this device file, but the device file no longer exists. If you deleted this file on purpose, try uninstalling the associated application using its uninstall or set up program. If you still want to use the application associated with this device file, try reinstalling that application to replace the missing file.
press any key to continue
same message
same message
Then when windows loads a message box appears unable to load the dynamic link library msnp32.dll. The system cannot find the file specified. Some or all of the following feature is not available:Microsoft Network
click ok
and windows continues to load.

A MS article suggests the following actions are needed to fix the problem:

To install and remove network components

1. Click Start, point to Settings, click Control Panel, and then double-click Network.

2. Click Add, click Adapter, and then click Add.

3. In the Manufacturers box, click (detected net drivers). In the Network Adapters box, click Existing Ndis2 Driver, and then click OK.

4. If you are prompted to enter a workgroup name and a computer name, fill in the appropriate boxes on the Identification tab.

5. Click OK or Close until you return to Control Panel.

6. When you are prompted to restart your computer, click OK.

7. After the computer restarts, click Start, point to Settings, click Control Panel, and then double-click Network.

8. Click Existing Ndis2 Driver, click Remove, and then click OK.

9. When you are prompted to restart your computer, click OK.

However after following these steps the error messages still appear on boot up.

Has anyone any idea how to fix this?

  Gongoozler 22:58 05 Mar 2004

Hi stephjh. This kind or problem can arise if you have a motherboard with onboard LAN. If this isn't disabled in BIOS, Windows installation can try to install Microsoft Network, but doesn't always load all the files.

You can extract the required file from your Windows CD using Start, Run, and type in the box "sfc" (without the inverted commas). Then select "Extract one file from installation disk". The file should end up in the Windows\System folder.

  Gongoozler 08:29 06 Mar 2004

I should have added that when I had this problem on a computer I was rebuilding for a friend I found it easiest to reformat the hard drive and reinstall Windows after disabling LAN in BIOS. In that computer it was in Integrated Peripherals - OnChip PCI Device - VIA-3043 OnChip LAN. Yours will probably be slightly different, but this may help you to track it down.

  Gongoozler 09:21 08 Mar 2004

Hi stephjh, did that solve your problem?

  stephjh 10:21 08 Mar 2004

no not resolved yet, any ideas?

  stephjh 10:24 08 Mar 2004

have been advised to say that I have been into BIOS and the LAN is disabled.

  stephjh 10:39 08 Mar 2004

thank you will give it a go

  stephjh 13:37 08 Mar 2004

ok I tried that but must have got it very wrong, as after a safe mode start up, I got my fixit disk out, and am now back to where I started, only with the exception of the file names are missing other than that I am still getting the same messages, please could you give me a more detailed idea of what to alter and what to alter to.
with thanks.

  Gongoozler 13:48 08 Mar 2004

stephjh, have you tried putting the files in where they belong?

  stephjh 14:10 08 Mar 2004

where do they belong?

  Gongoozler 14:15 08 Mar 2004


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

See the Best Button Badge Designs of 2017

iPhone X review

Black Friday 2017 : date, sites participants & bonnes affaires