microsoft .net framework problems

  Flying Teddy 18:52 02 Jul 2005

Tried to download a security update for .net framework, but it failed, quoting KB886903. This bulletin I found to be not very helpful.

After that I couldn't get rid of the update icon in the tray - there seems not to be any microsoft procedure for what to do if a download fails.. So I tried to uninstall .net from control panel, but it wouldn't do it (quelle surprise) quoting internal error 2711. S867460.

Right, thought I. I deleted all files and stuff relating to .NET Framework, and also any registry entries I could find. Then I did a clean up using Regseeker and CCleaner alternately until nothing else turned up. Guess what - that dratted icon is still there! So I downloaded .NET Framework again from and tried to install it, but guess what! Internal error 2711. S867460 again. It also stated that the setup had ended prematurely (thought that was just me!), with an exortation to contact Product Support.

So I now have a failed installation and a persistantly useless update icon.

1) Do I need .NET Framework?
2) If not how do I get rid of it?
3) If I do, how do I get it properly installed?

HELP!! all contributions gratefully considered...

  €dstowe 21:12 02 Jul 2005

Any chance of a System Restore to a time before this happened? Or, better, re-install from a backup?

  bretsky 22:04 02 Jul 2005

I had this problem when I tried to install the update to the .NET Framework so I aborted it.

In the windows updates it gives you the option to hide updates you don't want to download so you won't see it when updates become available.

Yes you do need the .NET Framework as some programs rely on this as a platform to operate, so you might encounter problems when installing various programs.

Judging from the threads on this subject, when I googled the error numbers, it's the Sp that's the problem, you need to uninstall your Sp then reinstall .NET Framework then reinstall the Sp, yes, long-winded, and I would follow €dstowes' advice, also, as the registry has been altered too.

bretsky ;0)

  Flying Teddy 23:18 02 Jul 2005

Unfortunately there's no restore point - looks like I'll have to do it the hard way! I'll do the dirty deed tomorrow and make with the green tick then. Just in case...

Thanks for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017