Micronet SP916GK on Virgin Cable

  User-519324 12:09 11 Sep 2007
Locked

Can someone help? I cannot connect to the internet when I use the above router connected to our cable modem. Micronet website states it is a cable /adsl router but is it possible it is incompatible?

PPPoE connection in router setup (192.168.1.1), have tried DCHP too. [email protected] and password also added to router config pages but still no connection (are these details even necessary for cable?)

DHCP on laptop, and direct connection works fine (but only with virgin software).

Flashing light on router, but status page shows it as disconnected. I've not played arount with MTU settings, but I think these only apply to adsl connections anyway.

Any suggestions of how to get the router working or test if it is a compatible router would be greatly appreciated.

  mgmcc 20:30 11 Sep 2007

Yes the router is a suitable Cable/DSL model for use with Virgin's Cable service. You use the DHCP setting, *NOT* PPPoE and you *DON'T* enter a Username or Password.

Power everything off, including the Cable Modem which must be left without power for three or four minutes - this is IMPORTANT so that it loses the association between the existing connection (recognised by its MAC address) and the IP address that it has allocated to it.

Connect a network cable between the router's WAN port and the Cable Modem's Ethernet port. Connect a second network cable between the PC's network port and one of the Router's LAN ports. Power on the Cable Modem and, when fully booted with all lights displayed, power on the Router. When the router is fully up and running, boot the PC. The Cable Modem will recognise a new connection and allocate a different IP address to it.

If you now type the Router's IP address into your web browser you should be able to open its configuration pages to set it up for wireless networking.

  User-519324 12:05 12 Sep 2007

Thanks gmgmcc - problem solved! Before I saw your post, after much more tinkering, I cloned the MAC of my PC to the WAN port of the router and changed the router IP to 192.168.100.1 (allegedly the IP used by Virgin cable modems) - One of these two actions seemed to do the trick and the router picked up its IP instantly.

Would the MAC-cloning would have had the same effect as turning off the modem for 3-4 mins as you suggested? I read elsewhere that MAC cloning was no longer necessary nowadays.

Incidentally should there be an IP for the modem that I can ping or access a web interface at? With both a direct and indirect connection, the modem seems invisible to my laptop. I have looked at IPconfig /all and pinged the IP listed under 'gateway' with a direct connection but this did not work. Is the modem supposed to be 'invisible' with a cable connection?

  mgmcc 13:19 12 Sep 2007

Cloning the MAC address of the network adapter that was previously connecting to the Cable Modem would make it work, because the modem would think it was the same connection and wouldn't need to allocate a new IP address.

<<< I read elsewhere that MAC cloning was no longer necessary nowadays.>>>

At one time it was necessary to register with the ISP the MAC address of the adapter that was being used to connect to the Cable Modem. If I remember correctly, a maximum of three MAC addresses could be registered. To avoid having to register the router's MAC address, it could simply clone the MAC address of the PC's network adapter that was already registered. The problem with this system was that a Laptop registered at one location couldn't then be used with another Cable Modem without unregistering it from the first and registering it at the second. Authentication is now via the Cable Modem's own MAC address instead of a network adapter or router's MAC address.

The Cable Modem's own IP address is normally 192.168.100.1 and typing this into your web browser should open its configuration pages. However, your router shouldn't also have this address and probably shouldn't even be in the 192.168.100.0 subnet. Give the router the address 192.168.1.1 so that it allocates addresses in the 192.168.1.2 to 192.168.1.254 range

  A/Z 13:33 31 Dec 2007

Need help
I have just bought SP916GK micronet router and I'm with virgin media
when I connect the cable modem or the computer to the router and start it, the indicator lamp (WAN or LAN) lights green for about 17 seconds and then turns off
no network is identified
do you think it's a hardware problem or am I doing something wrong

  JustinMcArdle 16:59 03 Feb 2008

I also have had problems since I replaced the cable thru the tv box to the Virgin cable modem I am running through LinkSys router and although the wireless connections worked ok the wired connection to the router refused to work. The NIC could receive a valid IP address from the DHCP server in the router.
I tried everything suggested in various forums but still couldn't get an internet connection via the wired NIC.
Then Bingo! Finally came across the solution - which is go to the Network Connection and go to properties-configuration-advanced. Link speed/Duplex is set to Auto Negotiation by default. Change this setting to 10Mbps/Half Duplex. You will now get a valid IP address (without rebooting) and be able to connect to the internet.

  User-1274874 10:31 22 Jun 2008

Justin - thanks for posting your message. Changing the setting to 10Mbps enabled my Micronet SP916GK to connect. (Virgin had told me it was a hardware problem & couldn't provide further advice.)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?