MFC42 DLL problem

  dewskit 11:02 13 Sep 2007

On start up I am getting the following message:

"The instruction at "Ox73dd11cy" referenced memory at "OXOOOOOO4" The memopry could not be "read"
Click OK to terminate the Program."

This is then repeaeds on clicking OK and the following message then appears after again clicking OK

"Exception EAccess violation in module MFC42DDD at 000011C7
Access violation at address 73DD11C7 in module MFC42DLL
Read of address 0000004"

I am also experiencing log in problems with BTYahoo Browser, being repeatedly requested for my user name and Password. Have managed to get on-line using Internet Explorer.

Did a search of the forum before positng and offers of several 'free' Registry fixes appear, but turns out they only do a free scan, one of them claims to find 617 errors but then needs full registration for any useful help!

Any advice for a free fix please?

  johnnyrocker 11:32 13 Sep 2007

what os have and what anti spyware do you already have on board.?


  johnnyrocker 11:34 13 Sep 2007

you may be able to find more help by click here=


  dewskit 11:56 13 Sep 2007

Windows XP Home and Norton (via BT)
A Squared (full), Spybot S & D Adaware Spyware Blaster all installed

  dewskit 19:35 13 Sep 2007

Thought I would try and see if Restore would help, but all restore points give cannot Restore message

  skidzy 20:02 13 Sep 2007

You need to turn off Norton for SR to work.

Possible cause:
1. Click Start, click Control Panel, and then double-click Internet Options.
2. On the Advanced tab, disable third-party browser extensions.
3. Restart the computer.

  dewskit 21:25 13 Sep 2007

Hi Skidzy

Thanks for the suggestion, but sorry to say it did not work!

Will try disabling Norton and attempting to Restore again. Will report back here with outcome!


  skidzy 21:31 13 Sep 2007

Something to try Tony. Winaso

click here (regopt version) trial but unlimited and will fix 10 errors at any one time,though you can rescan and repair as often as you like.

Also run SAS Superantispyware click here free version.

Some more apps and advice click here

  dewskit 21:48 13 Sep 2007

Thanks skidzy

Have tried system restore three times to different points back to mid August without any joy, having previously disabled Norton Firewall and Anti-virus and A squared Guard (after going off-line of course!)

Will now proceed to work through you other suggestions

Thanks again


  skidzy 22:05 13 Sep 2007

Also try the system file checker;

start / run / and type
sfc /scannow
Note the space /

understanding sfc click here if you have a corrupt system file dll this should replace it.

  dewskit 22:40 13 Sep 2007

Hi again skidzy

Well, Winaso claimed to have fixed 169 errors!

Have tried sfc scannow twice and got a Blue Screen of Death each time saying the system has been shutdoiwn, so not sure where to go from here.

I have to be up at 6.30 tomorrow, so am calling it a night for now, will try again tomorrow and report back here if anything useful shows up.

Many thanks for your patient assistance


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?