Messing around with registry!!

  spuds 17:17 28 Nov 2009

I am trying to download some programs from disks, but I am unable to do so, either on autorun or via My Computer clicking on the relevant device.

I have managed to get as far as the following message, but at present I am not sure if I will cause more harm than good.

8.3 Name Creatiopn disabled.

The creation of 8.3 filename and directories for NTFS partitions are disabled.

Please enable the 8.3 filename creation for the TIS 2000 installation.

Start REGEDIT32.EXE and locate the registry subkey 'SYSTEM\Current\ControlSet\Control\FileSystem'.

Set the entry 'NTFS Disable8Dot3NameCreation' to 0.

Doe's that make sense, because it doesn't to me, and I do not want to attempt to do changes, if it is going to bring further problems on an already acting up computer.

Any advice/help gladly received and appreciated.

  Forum Editor 17:29 28 Nov 2009

It's all to do with the filename length. Setting the value to zero will not affect your files in any way, but it affects the way that NTFS manages them.

Follow the instructions, and save your changes. Windows will prompt you to save a copy of your registry before you make the changes - do so, and save the file to your desktop. Once you're happy that everything is running OK you can delete the saved copy. Give it a few days though.

  spuds 11:53 30 Nov 2009

Thank you FE for the response, but can I ask a further question as to why this as only just occured. Previously I have installed from disk and downloaded from the net many times, without any problems of getting the product to do the job intended. Yet on this first occasiom, the program is suggesting that I make changes. Even the supplier of the disk cannot understand this, and as sent a replacement disk which now as the same problem!.

  woodchip 12:06 30 Nov 2009

As FE follow what it says, its easy to do as long as you touch nothing else

  woodchip 12:07 30 Nov 2009

A program install or a download etc may have changed the settings prior to what you are trying to do

  spuds 17:56 02 Dec 2009

Thanks for the response, much appreciated.

Now another problem: Regedit32.exe is now apparently Regedit.exe. On locating that, I am informed of four possibilities but no subkey. So possibly I am doing something very wrong. Can you please walk me through the process to actually find the part that I want?.

  woodchip 20:18 02 Dec 2009

If this is XP its in a different Place to what they said on my XP Home Laptop.

Start Regedit by typing Regedit in Run press enter then

Right Click on 'NTFS Disable8Dot3NameCreation' to 0.
Choose Modify
If it not set to 0 you need change it to 0

  spuds 19:23 12 Dec 2009

Thanks again for the response, but I haven't been able to locate 'NTFS Disable8Dot3NameCreration'. In HKEY_LOCAL_MACHINE... it just keeps coming up as (Name) AB Default (Type) REG_SZ (Data) Value not set.

Tried this on two computers, one with XP Home, othervwith XP Pro.

Apologies for being a nuisance!.

  woodchip 19:43 12 Dec 2009

Okay try it this way, go to run type Regedit press enter, go to Edit\find in the Menu type
NTFS Disable8Dot3NameCreation

click on my computer top left in regedit before you click on okay button so it searches the whole reg. if it finds it right click on it and modify as above to go to next press F3

  Coff 21:56 12 Dec 2009

Copy and paste the following into Notepad and save it as NtfsDisable.reg (the important thing is the .reg extension).

Windows Registry Editor Version 5.00


Double click the NtfsDisable.reg file you've created and click ok to the prompts and the subkey will be added to your registry with a value of zero.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?