Messed up my boot.ini file, help! Tried everythin

  TicTacToc 09:16 17 Sep 2006
Locked

Hi all,
I have messed up my Windows install, I will try and explain the situation:

I have a 160gb IDE Seagate HD with my Windows XP Home Install and all my other documents on the same 1 large partition.

I recently got 36gb Raptor for my Windows install. I also installed XP Home on that HD. However, I wasn't ready to start setting up all of XP, so decided to have a quick go with Vista. After another format I had a clean Raptor.

Of course however my boot.ini file had two OSes to load from, both under the same name. This was annoying as I had to chose the bottom on everytime Windows booted so I actually got an OS to load.

I figured I could go into my boot.ini file to change this. So I went in to it and deleted what I thought was the line of code that related to my non-existent install of Windows XP on my Raptor.

But it $"&"($& was the wrong one, and I deleted my actual OS install part, meaning I could not boot as it wouldn't boot my actual windows install.

Anyhow I can change the boot.ini file without booting into windows? I can boot from the Windows XP disc and go to the recovery console, but 'fixboot' doesn't work (well it says it does but nothing changes) and when I try thee 'bootcfg' it says something about my Hard Drive being corrupted. . .

I'm trying to install Windows on the Raptor Hard drive again, it all goes well until I need to reboot, and nothing happens: I either can boot from the disc and be back to the beginning, or get an OS Load error message

That probably wasn't very clear,
but from what you can understand, any advice?

I cn't belive deleting the wrong line can turn things so much for the worse. I have tried everything for the last three days:

Partitioning my main hd and installing Windows on the freee partition - however I just get the OS Load error message as above. .

Booting Knoppix although I can't find anything of interest in there to affect my boot.ini or anything.

I have tried using the recovery console, but I can't get pass the 'adminstrators password'. What the hell is it? The adminstrators account password won't work.

Any help?
Thanks

  STREETWORK 09:23 17 Sep 2006

Try and reinstall the recovery console

click here;en-us;307654

  VoG II 09:25 17 Sep 2006

click here

and STREETWORK's link should be click here

  STREETWORK 09:36 17 Sep 2006

Ohhps...

  PSF 11:26 17 Sep 2006

just press enter when asked for password.

If you log into the recovery concole and type fixmbr it will re-write the MBR, you will loose the vista entry but you can re-install as RC1 is now out.

  TicTacToc 15:33 17 Sep 2006

thanks for the info all, but I managed to sort out the problem by installing another Windows copy onto the same partition and hard drive but a different folder.

This allowed me to get into windows and change the boot.ini file so it would boot my original Windows.

Your links are still useful though - thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?