Mesh PC SATA 2 Drive recognition problem

  Inside Edge 14:48 09 Jan 2009
Locked

Hi to all out there.

I have a problem with installing a new 1 Tb Seagate SATA HDD. I’ve trawled this and other forums and seen that many others have similar issues, but what’s worked for those who have sorted it either doesn’t work for me or seems not to be applicable.

History:-

Mesh Matrix 64 FX-Xtra; Asus SK8V; Athelon FX-51; 1 Gb RAM; Win XP SP2; AMI BIOS version 08.00.09

2 existing Maxtor SATA HDD’s on SATA 1 and SATA 2 MoBo ports (VIA 8237 controller) exactly as originally installed, configured and supplied by MESH. i.e Promise Controller disabled.

All this was working fine but the C:\ Drive (120 Gb) holding the operating system has been making horrible clicking noises and regularly crashing the PC so I’m replacing it. I backed up the drive contents to an external drive using Acronis and intended to restore it to my D:\ Drive (250Gb) making that the bootable drive and then change out the flakey one. I had some difficulty getting Partition Magic to resize and add partitions to the D:\ drive – it kept returning errors including an indication of formatting errors in the existing Partition and failing to complete, so I decided to restore the C:\ Drive image to the new drive instead and sort or scrap the old D:\ Drive afterwards.

I began by swapping the D:\ Drive for a Samsung 750 Gb SATA 2 drive straight out of the box. On boot up, the PC failed to see the new or the old SATA drives and wouldn’t boot to Windows. I checked all the connections/cables, but if I put the old D:\ drive back, it booted fine. Online forums suggested that many folk had problems getting their BIOS to see this particular Samsung Drive and Samsung website documentation was poor and contradictory so I took the drive back to the shop. There they initialised it and formatted it as unallocated space (NTFS). I tried again but still the BIOS said no drives found. I reviewed BIOS settings but there is little to alter and anyway it all works with the existing drives.

The issue appeared to be that the new SATA 2 drive has the faster data rate of 300 Mb/s which is not supported by my MoBo. Samsung blurb says this can be overcome by fitting jumpers to convert the drive to the old 150 Mb/s SATA standard, but their diagram had 8 pins vs the 4 pins on the drive. I tried all possible jumper positions but the drive was still not seen. Note that the BIOS doesn’t see my existing C:\ drive either if the new one is connected. If I connect only the old C:\ drive, it boots to Windows OK.

Samsung and other sources advice to configure the drive in the BIOS manually doesn’t work because, a) there’s nowhere to input SATA drive parameter data in the BIOS and b) Samsung don’t put the sector, block, heads data on their drive datasheet anyway !

I took it back again and changed it for a 1Tb Seagate Barracuda. The documentation and support was better, but I was still expecting to need to fit jumpers to reduce the transfer speed. The shop formatted the drive and I fitted the jumper as per Seagate instructions, …….same result, neither SATA drive is seen by the BIOS.

I’ve not updated the BIOS because the ASUS site says don’t unless you’re confident it’ll solve the problem. Since their list of BIOS mods doesn’t seem to relate to my issue, I couldn’t be sure it’d make any difference. I’ve also not installed any new Windows SATA drivers as this seems to need to be done when you install XP (not sure why, but that’s what I keep reading in the forums) and I’d rather not re-install XP when apart from this drive issue the PC works fine. In any case, it’s the BIOS that can’t see the drive – XP hasn’t had a chance to look yet !

I would be very grateful for any help and advice that’ll get this thing working. Could a BIOS update for the SATA controller chipset be the answer (the VIA 8237 ) ? If so, where would I download it from and how would I go about installing it?

Many thanks in anticipation

  Jim_F 15:14 09 Jan 2009

Provided the second SATA channel is enabled in bios I can't think of too much unless its the SATA connectors which seem to jump out at the slightest provocation.

Just a thought is the first SATA channel onboard with the second one via the promise controller ?

  Jim_F 15:34 09 Jan 2009

AS a follow-up I believe the Via chipset just supports 2 drives (either straight SATA RAID 0 or RAID 1) so your 3rd drive would need to go on the Promise controller.

  Inside Edge 15:52 09 Jan 2009

Hi, thanks for the prompt response.

In the BIOS, under "advanced"; "Onboard Devices Configuration" you enable either the two independent SATA connectors ( by enabling "Onchip SATA BOOTROM" ) or the two SATA RAID connectors (by enabling "Onboard Promise Controller" and then RAID or IDE Operating Mode) - or of course both. My drives are connected to the independent non-raid sockets which are controlled by the VIA VT8237 chipset.

The mystery is that everything that needs to be enabled/set up to run 2 SATA drives in this way is already done, because that's how they operate now and have for the past 4 years, without a problem. If I plug the old drives back in they still work fine (apart from the horrible noises intermittently emanating from the C:\ drive. i've never had any problem with loose/faulty or otherwise unreliable connections. The new drive is warming up when connected, and sounds like it's spinning, so the power supply to it seems ok.

  Inside Edge 15:57 09 Jan 2009

Hi, ...On your last point ..... I had understood that to set up a RAID configuration, you have to connect to the Promise controller. I believe the VIA chipset only supports SATA drives running independently.

...at no point have I connected more than 2 drives at once by the way, but perhaps I should try sticking the new one on the Promise channel anyway ?

  Jim_F 13:13 10 Jan 2009

Yes sorry I misunderstood - if you've swapping like for like on an existing controller it should be OK. It would be worth checking on the promise controller just in case the Via one had a thing about newer SATA drives.

Also worth noting that drives over 128 Gb use extended LBA (48 vs 28 bit) - I'd expect the board to support this but can't tell from the specs.

BTW the last point I took from the spec - that it is a 'dual RAID' board.

  Inside Edge 22:27 11 Jan 2009

Update.....

I've managed to ge the Drive up and visible by both the BIOS and Win XP.

I entered the BIOS, enabled the Promise Raid Controller and set it to IDE Mode (ie non-raid). I downloaded the latest driver for said Promise Controller from the SK8V section of the ASUS website. I then connected my new drive to the SATA Raid 1 socket, leaving my drive containing XP connected to the independent SATA socket. On re-boot, the drive was recognised in XP as new hardware and I was prompted for the Promise SATA driver. I installed it from floppy and I specified the location. I was also prompted for the Promise SCSI driver which I installed although I don't know why it was needed. The disk shows up in XP Disk Manager as the full 1Tb in NTFS format (well, 936Gb to be precise). Strangely, Partition Magic sees it OK, but as being in "other" format, which it labels as "BAD" although it doesn't claim there is any problem with the drive nor explain whay BAD means ??? ....I don't think this is meaningful - I lost faith in Partition Magic a while back !

There's no obvious reason why it didn't get recognised when connected to the SATA 2 independent socket, but maybe an updated driver would sort it. The latest driver on the ASUS site is dated 22 Oct 2003 - 2 months before I bought my PC, so it might be more recent than what I have.

I will re-post if I have any further problems in operation. Thanks for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?