Memory Stick Not Showing Up Correctly

  SantasLittleHelper 12:56 16 Jan 2006

Hi All, I have a 256Mb USB memory stick, when I insert it into a USB port it shows up in "Windows Explorer" and "My Computer" correctly as "I" Drive and as a removable disk, but when I click on it it comes up with message "Insert disk in drive I". Have tried removing and re-installing the software, rebooting computer, with memory stick both in USB port and left out. If I attempt to format the memory stick it asks me again to insert disk in drive "I". Any ideas anyone, or is time to consign to the bin?

  xania 13:02 16 Jan 2006

What version of Windows? Has the stick always had the problem or is it new? Have you tried the stick on more than one PC?

  [email protected] 13:16 16 Jan 2006

Is there anything on the stick?

  SantasLittleHelper 18:58 16 Jan 2006

Hi, sorry for delay, this work thing keeps getting in the way of important stuff! I am running Windows XP Home, the pmemory stick is about eight months old and has performed faultessly up until now. There is data on the disk but nothing that can't be replaced.

  SantasLittleHelper 18:59 16 Jan 2006

p.s. it is the same on any PC I try it on

  lindyloo4 20:12 16 Jan 2006

I'm also running XP Home and I have a built in card reader. It started acting up in the same way a few months ago. Instead of my Compact Flash card registering in that postion ( Drive E ) it thinks it's Smart Media ( Drive F ). I just open Drive F and then have no problems. If I try to open Drive E it tells me to insert a disk, even though that is where my disk is inserted.

Try opening a different drive, it might just work.

  LivEviL 20:18 16 Jan 2006

have you tried naming the memory stick a different name on a diff computer! then try inserting it in urs! that way u can tell weather that removeable disc is yours or a printer or card reader or somthing! also have you clicked on control panel>system>hardware>device manager>universal serial bus controller to see if its there? in the properties it will have the make of the memory stick!?!?!?!

  SantasLittleHelper 13:13 17 Jan 2006

lindyloo4, have tried opening all other drives but to no avail.
LivEvil, have checked in "Device Manager", it is showing correctly as "USB Mass Storage Device". Have tried renaming device but still asks for a disk to be inserted.

  CLONNEN 13:38 17 Jan 2006

Is it showing in Disk Management screen at all?

Right-click My Computer icon and select Manage.

Should be formatted as FAT32 or NTFS. If it is showing anything else reformat it.

  SantasLittleHelper 19:36 18 Jan 2006

Hi, will not allow me to format it, it comes up with "No disk in drive, insert disk and try again". Went and bought another memory stick today, inserted it and it works fine. I have to assume the old memory stick is duff and bin it. Thanks to all of you for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?