memory stick help Not working !!!!

  cliff100 12:52 12 Nov 2009
Locked

I have a 64GB memory stick that has decided not to work as you can understand I do not want to just chuck it and get another one as it was expensive. If I put the stick into a PC it shows up once ( works fine). If I then remove it ( correctly ) and put it in again it just comes up as a flash drive and I am unable to view any of my files. Has anyone any idea on how to fix, at first I thought it was because the drive letter was already taken on the PC and so I change the drive letter of the USB and that still did nothing.

Thanks Cliff

  peter99co 13:12 12 Nov 2009

64 gig? are you sure

  peter99co 13:24 12 Nov 2009

I got a stick back into use by a quick reformat but you lose any data of course.

The drive letter will be whatever is available when you connect and to change it yourself seems wrong to me.

Can you see it and it's properties in My Computer?

I only remove sticks after my system has shutdown. Safely remove let me down once.

  cliff100 21:17 12 Nov 2009

hi yes I re formatted it once and nothing :

this is the type click here

I have just tried it again and it comes up with E drive and a picture of a removalable disk but when you click on it it just states insert a disk.

Not sure what else to do

Cliff

  peter99co 22:17 12 Nov 2009

E drive on my machine is the DVD/CD drive.

Is the Property option available?

  PP321 22:38 12 Nov 2009

Right mouse click on "my computer" , and choose "manage" , the click on "disk management" , then look for your pen drive in the bottom grey panel, right mouse click on it and choose "change drive letters and paths" , change its drive letter to "H" for example, wait a few seconds then try to use it, see if your fines are there, if not, then format it and see what happens.

  cliff100 23:09 12 Nov 2009

I thought we nearly had it then, the property options are available and I tried everything from PP321 suggested. waited a few secs and tried to open or explore and it just says insert disk into drive U. when I look at the drive in manage drives it just comes up as no media.

cliff

  I am Spartacus 23:18 12 Nov 2009

According to the datasheet it has a 5 year warranty.

It may be that it has a hidden partition for the security software and that is causing problems.

  cliff100 14:39 13 Nov 2009

Not sure how to look at the hidden partition,
I have taken this to work today and spoken to my IT chaps they say it's no good.
So it looks like it's back to the loads of little cheap ones.

  Sea Urchin 14:51 13 Nov 2009

>> 64 gig? are you sure <<

I assume you were surprised by the capacity of the stick - but you can get at least 128GB flash drives now

click here

  Terry Brown 16:13 13 Nov 2009

I would suggest , that as it is under a 5 year guarrantee, as it has been checked by your IT staff,I suggest the following:

You say you put it in once and it works OK, Copy all your data to a hard drive or DVD, do a full (not quick) format, and try again, if still no good, return it to where you bought it as Faulty.

I assume you still have the purchase / payment documents.

Email the company first for the correct procedure on returns.
Terry

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?