Mem Test Failed - help ?

  Derek 11:24 20 Feb 2003

K7S5A, Win 98Se, 2 x 32m mem, single HDD, CD, Floppy.

Can you help please.
I switch on and the boot starts, it tests the memory and shows 65536k ,it goes through the drives and lists them . It then stops with the message "MEMORY TEST FAILED".

After this I'm prompted to press F1 (I think) and the Win logo appears and at some stage it tells me that HIMEM.SYS is missing.

History, it's a machine that I built about three years ago and has always worked perfectly, I passed it on to a most intelligent friend who made some attempts to install an Xmas gift of a wireless mouse (USB). Apparently all went well until he was invited to load the driver from a supplied CD. At this stage, the story gets a little blurred and I suspect that some wrong buttons were pressed. However, to save embarrasing me he contacted his son who brought along another version of Win 98 and attempted to load it. And that's it, I now have the machine back to fix.
I've 'emptied' the CMOS and reloaded the default BIOS settings, I've attempted to put back in the proper version of Win SE but half way through it goes through it's proceedure to restart and the machine reverts back to "Memeory test failed", I've done a Scanreg /restore.
Please what is the next step.

Regards DM

  DieSse 11:32 20 Feb 2003

Replace the faulty memory is he next step.

  BrianW 11:42 20 Feb 2003

I think my first step would be to see if it is indicating that one (or both) of the memory chips has failed. Take one memory chip out and try booting up. If you still get the same message, replace with the other chip. If you get the same message with both then either both are faulty or it may be something to do with your Config.sys. Before you attempted to re-install the Win98se did you reformat your hard disk or are you trying to re-install over the old version already present?

  DieSse 11:48 20 Feb 2003

The memory test in the post has nothing whatsoever to do with anything on your hard drive. It's a program run from the BIOS before your hard drive even gets detected.

Other than faulty memory (the most likely cause by far) - it's just possible the BIOS settings for the memory may have been changed, and it's trying to run at a speed too fast for it's specification.

You can also try taking out the RAM, and cleaning the edge connector with alchohol. Sometimes connector metal mismatches can cause corrosion - for instance a copper socket, and tin-memory contacts - or vice versa.

  Derek 12:13 20 Feb 2003

Many thanks for all your advices, I now have sufficient to get back on stream.
Again many thanks Derek Miles.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?