media player win32 error

  sky_123 18:49 17 Dec 2007
Locked

Hi guys
I've done a search and can't find a solution to this problem. Basically I had windows vista and cause of the slow activity I downgraded to XP but now my media player won't work. If I click on the drive I get D:/ is not a valid win32 application. D being my CD drive trying to use media player to plays CD's or DVDs. I can play them through other applications so its not the drive thats faulty.
I've tried downloading wmp 11 and it won't load just gives error messages. I download 10 and it says its not compatible with my version of windows.
The error messages I get whilst trying to install are
C:\programfiles\windows media player\wmpnetwk.exe is not a valid win32 application

C:\programfiles\windows media player\wmpenc.exe is not a valid win32 application

C:\programfiles\windows media player\wmpenc.exe is not a valid win32 application.

then the download closes.

can anyone help or tell me how to remove wmp totally and recommend another application that works the same way. I tried add/remove programs but it didn't uninstall it completely.

thanks

  brundle 19:25 17 Dec 2007

Get MS Installer cleanup and remove remnants of WMP click here

Reboot

Get CCleaner click here, clear temporary files, run registry cleaner

Download WMP11 here; click here

Install.

  sky_123 12:39 18 Dec 2007

Hi
thanks for your response. unfortunately it didn't work. I got the same 3 error messages upon install.

I removed all the files that came up on the Ms installer cleanup and the CCleaner and then downloaded WMP11 but got the same problem.

will reinstalling xp help?

  brundle 18:41 18 Dec 2007

It should solve the problem altogether. When you `downgraded`, was that via a complete format and re-install of XP too? You shouldn't have to repeat that process but then again if it was only recently you won't lose much in the way of configuration settings.

  sky_123 03:42 19 Dec 2007

Hi
I booted off the CD and saved to the recommended partition. nearly all of my old files are still on the machine so maybe not a complete format. Ok I will give it a go. thx

  sky_123 21:05 19 Dec 2007

I reinstalled the same way and had the same problem so did a full format and it all appears to be fine. just need to reinstall all the software and drivers now. thanks for your help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017