Media Player - stop from playing cd when inserted

  andy625 17:29 02 Feb 2006
Locked

How can I stop Media Player automatically playing a cd when I put one in the drive? I am currently ripping my cd library to pc, and have to stop it playing each time I put a different cd in.

I've tried everything I could see in options. I've set it to rip cd when inserted, it doesn't do it for the 1st one, but after that it does. Plays every goddam time though!

I am running WMP9 on w2000.

  Stuartli 17:33 02 Feb 2006

Have you checked the AutoPlay configuration?

  andy625 18:36 02 Feb 2006

I've just had a look, and unless I'm going blind, I can't see where it says autoplay in the media player options. Could you give me some clues?:)

  malgall 18:44 02 Feb 2006

if you have xp
goto my computer right click on cd drive
in the menu click properties then next
autoplay
this is where you can tell it to run
which program when cd is inserted

  andy625 09:33 03 Feb 2006

Unfortunately I have Windows2000. I checked the properties of the cd drive and there is no setting for autoplay.

I read on the microsoft site, that you can tweak the registry to stop it from autoplaying. I did the tweak last night, and although it didn't work instantly, they did say that you may need a reboot. It was late, so hopefully tonight it may be fixed...?!

  pj123 11:56 03 Feb 2006

Try Control Panel, System, Device Manager. Select your CD, go to Properties and take the tick out of Auto Insert Notification.

Don't know whether that's the same for W2K as I am on Win98SE.

  andy625 12:05 03 Feb 2006

Thanks pj, I'll check that out when I get home.

  pj123 12:58 03 Feb 2006

Sorry, should be Properties, Settings.

  driving man 15:07 03 Feb 2006

quick answer hold down "shift" until autoplay has finished trying to start

  andy625 11:40 07 Feb 2006

When I go to device manager, properties of cd drive, there are no setting relating to autorun.

When I did the registry tweak, WMP wont register that the cd is inserted at all, so I had to change that back.

Holding down the shift key works, but I was hoping to be abe to just put in the cd and leave it to its own devices. I have a couple of hundred cd's that I want to rip.

I take it that there is no easy answer to this then?

  billyliv 11:58 07 Feb 2006

Start->Run...

Type in 'regedit'

Open the following:


HKEY_LOCAL_MACHINE
SYSTEM
CurrentControlSet
Services
Cdrom

On the right side, set the key named 'Autorun' from 1 to 0. Then, restart Windows.

Now, Autorun will not activate when CDs are inserted. This will prevent silent apps from installing through the Autorun process. No more problems from Sony or any other DRM systems that use Autorun to install their fodder.

Disabling Autorun is probably a good idea anyway. Autorun was a stupid idea from the beginning. Nothing should ever just 'automatically' run on insertion. This activity just begs for security problems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache