MD-DOS compatibility mode file system

  Tj_El 16:12 10 Feb 2003


Have rebuilt an old Win98SE PC for the children and was doing a scandisk/defrag and came across the message: Drive D is using MS-DOS compatibility mode file system. I think Maxtor's MaxBlast was installed on one of the drives in use hence this message.

I have tried to access drive D but can't. Is there a way to tell what partitions exist in the system and what they consist of in Win98SE? I know I could do so using the fdsik command via a boot-disk. Trouble is the floppy drive is kaput so I can't use the drive. What other tools come with 98Se that can enable this or does it come down to using 3rd party software?

Thanks for all your input & suggestions.


  Tj_El 16:33 10 Feb 2003

...I don't have any device conflicts showing in Device Manager...

Maybe I should go buy a new floppy drive and use FDISK...?

  BrianW 16:37 10 Feb 2003

Could you restart in MS-DSO mode and then go throught the C:\ to C: prompt the DIR, D:\ to D: prompt then DIR etc? Form memory this, somewhat laborious method should let you check what partitions you have. Also, if you get into cmos, can you change your HDD settings to auto and force it to show?

  BrianW 16:38 10 Feb 2003

spot the typo - start in MS-DOS mode - of course

  Tj_El 16:44 10 Feb 2003

Thanks BrianW.

Tried it. Result? Not ready reading drive D Abort, Retry, Fail?

So drive D does not exist - that's why I believe it's a partition on probably the C drive.

  Switcher 17:00 10 Feb 2003

You should have a copy of FDISK.EXE on c:\windows\command.


  Tj_El 17:21 10 Feb 2003

Thanks Switcher!

I now see I have 2 drives C and D....

Drive C details: Status = A, Type= PRI DOS, Mbytes = 1034, System = FAT16, Usage = 100%

Drive D details: Status = <blank>, Type = PRI DOS, Mbytes = 504, System = FAT16, Usage 49%

Drive D is a partition of sorts but not accessible in Windows. Under Windows it shows as having 0 bytes.

Drive E exists in Windows as a 1GB local disk but does not show up under FDISK??!!!

What's going on here? Shouldn't I see all available partitions and their types using FDISK? If so then is it possible that drive D is actually drive E and that somehow the naming of drives has gone wrong?

Your advice appreciated.

  Sam Witch 17:28 10 Feb 2003

this could be spsce for a drive for a compacted drive system,(or something for an old drive encryption.) win98 should allow you to access, try the doublespace in help

  Tj_El 17:43 10 Feb 2003

Hi "Sam Witch",

I have never used DoubleSpace or compacted a drive so it's unlikely to be that but thanks anyway... :-)

The story so far:

System performance tab message:

Drive D is using MS-DOS compatibility mode file system.
Drive D has 0 bytes
Drive D is partition 2 with system FAT16, of type PRI DOS with no status and 49% usage!

What is baffling me is the apparent presence of a drive with 0 bytes yet with 49% usage and which cannot be accessed.

I'm confused...

  Sam Witch 17:51 10 Feb 2003

Have you used one of the hidden drive programs like scramdisk , try the DOS command Unmount or Mount with the drive letter after,

  Tj_El 18:40 10 Feb 2003


Tried it but cannot unmount drives as they are not compressed drives...

Any other ideas?



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Comment créer un compte PayPal pour payer en ligne ?