MBR Problems

  agarm11 22:32 26 Nov 2004
Locked

Ok here goes, Pc had boot up problems (win XP Pro), Fixmbr was tried but on the wrong hdd (a slave hdd containing date only). Eventually got PC to boot from 1st hdd, but now slave hdd is only picked up by bios and not in windows. I suspect that the running of "fixmbr" on this drive when it didnt need it, has screwed it up. Any advice on sorting the problem would be helpful.

  bluesbrother 22:43 26 Nov 2004

You need to sign up to see the solution (if any)

click here

Good Luck

  agarm11 22:55 26 Nov 2004

Call me a tight b***er, but I really dont fancy paying for the info. :-)

  Jeffers22 23:11 26 Nov 2004

Try this. If you have the space, copy the data to the first HDD and then run fdisk on the second HDD setting it to logical - not primary and active. Once it's reformatted copy the data back. If you have Partition Magic you could perform the same operation without (in theory) harming your data. I would still back it up though. If not got PM try downloading a trial version of a partition utility.

  bluesbrother 23:30 26 Nov 2004

From one tight B****r to another, neither would I.

I didn't realise you had to pay or I wouldn't have posted the link

Hope you get it sorted

  smudge101 23:36 26 Nov 2004

There is a kill or cure method. You could delete the mbr from the 2nd hard drive. First of all you would have to install as the master drive.

Warning: this could lose all data and may not work on an ntfs drive (never tried it).

Boot from a floppy, there is and undocumented Fdisk option:
fdisk /mbr

If you choose to do this I hope I have made plain that you do so at your own risk

  agarm11 23:55 26 Nov 2004

First of all thanks for the reply jeffers22, but I can't get at the data to copy it across.

  agarm11 00:25 27 Nov 2004

Thanks smudge101, I just tried fdisk /mbr, no change, XP still doesn't see the hdd.

  agarm11 00:49 27 Nov 2004

In fact it would appear that I can't even see the hdd in dos, only the bios can see it :-(

  hillybilly 00:57 27 Nov 2004

Have you tried this? click here

  agarm11 01:36 27 Nov 2004

Hi hillybilly, the thing is that the drive is only a data drive, and even in recovery console its not picked up. The drive can be seen by partitionmagic 8.0 using boot floppies, but I'm not able to do anything that will sort the problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?