Maxtor safetydrill boot disk will not load

  JamesGLang 01:52 07 Feb 2009

Hi all
I am new to this forum and not much of a forum user at all.
So please forgive me if I ramble on, or/and don't give the correct information
but I have an issue that is beyond my knowledge and a google search isn't getting any hits that help

This is a kind of can you help me and a BEWARE (things don't always work out)

I have a Maxtor USB drive that came with an application “SafetyDrill” to backup an “image” of a computers hard drive partition(s). The software to create the partitions has been installed on four machines and has successfully created backups of all four machines disk(s)

I have since twice used the provided CD to reload two machines which had become corrupted due to, one disk failure and one suspected malware attack, these both ran without a problem but today the drive on my laptop packed in (Acer Aspire 5670), no S.M.A.R.T warnings ever showed, I just left the machine running at lunch time and when I returned the disk had gave up,

So a quick trip to the shops and came back with a nice new 160gig SATA drive. Swapped out the old drive for the new one , booted to the BIOS to make sure the new drive was detected (all good)
then shoved in the the safetydrill CD, set the boot option to CD first so the safetydrill software would boot first then I re-booted

The CD kicked in but locked at about(ish) 20% load
I thought OH, might be the CD is stuffed so I got the latest ISO from the manufactures site, burned it to disk (using one of those other machines) and tried again, but same thing happened.

So I thought might be the CD/DVD reader on the local machine (don't use it often so it could have stopped working), so I dug out my USB DVD and tried that having changed the BIOS to boot from it, but same thing, hung at about 20%

The safetydrill disk loads a Linux shell into a ram drive (when it loads) and that then interacts with the Maxtor USD drive, to copy the saved image to the local hard drive.

I can successfully load other Linux based OS software, Ultimate Boot CD as an example
(At least I think its Linux based) as an aside I like that software got me out of trouble once before

I did get my laptop running again using the Acer boot recovery CD ,but, just unhappy that a so called recovery strategy failed on the one machine that counted “Mine”

I thought about sending a snotty email to Maxtor but I took the time to re-read the documentation that came with the drive and it does state along the lines of
(make sure you can boot from the safety drill CD before you relay on it as a backup solution)
or words to that effect

Get out of jail card I think (along the lines on might work, might not, but its for you the consumer to decide)

OK to the point does anyone know how to fix or why I can't load the safetydrill software on my Acer Aspire 5670 laptop but other machines that I own don't complain

Thanks in advance

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?