Maxtor mass storage 3200 not being shown - help!

  pagget 22:29 12 Oct 2007
Locked

Hi

Any help would be really appreciated, i am absolutely terrified that all the photos on my external hard drive have been lost (i know i am stupid for not having back up!)

I bought the external hard drive a couple of months ago and it has worked fine, it now has dissapeared from My Computer, when i go into device manager it does appear as Mass Usb storage but not under the disk drives bit. I am a complete beginner so if any answers are out there could you please explain them in thicky terms!

the light is on and it is plugged in to the one of the USB ports. I have tried all the ports and am using a Toshiba laptop.

All my family photos are on there and i would be gutted to loose them.

Thanks

Sue

  GANDALF <|:-)> 22:51 12 Oct 2007

Go to start-control panel-administrative tools-computer management-disk management and you should see the disk-right click and choose 'change drive letter-select 'change'- select anything over the letter P such as T, U, w etc., from the drop down menu. Click OK and go to 'my computer' to see if your drive has appeared.

G

  pagget 22:57 12 Oct 2007

Thanks for replying, it doesn't show the disk drive, only the c drive and the cd drive. I am so worried that something is seriously wrong

  GANDALF <|:-)> 12:22 13 Oct 2007

Try the disk on another computer to see if it is recognise and also see if you can get another USB lead as the one that you are using could be faulty. This may be a stupid question but have you ensured that there is power going to the disk?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone