Maxtor 6 L200P0 External Hard Disk Problem HELP!

  [email protected]!nD 02:37 31 Aug 2005

Product Contents
USB 2.0 3.5” HDD Aluminum External Mobile Enclosure
USB A to B Type Cable
Installation Driver CD
5V/2A & 12V/2A Switching Power Adaptor
AC Input: 100~240V
AC Power Cable
Plastic Stand

Product Features
Supports USB 2.0 Transfer Rates Of 12 MBPS & 480 MBPS
USB 2.0/IDE Compliant
Supports ATA PIO Modes 0-4 & UDMA Modes 0-4 Of Operation
High Speed (480 MB) & Full Speed (12MB) Support
Allows Device Hot Swapping (Plug & Play)
Support Ultra DMA66 & Compatible With Ultra DMA 100
Support HDD Over 250GB
CE/FCC Approval
Self Power (Power Consumption 5V/1.5A & 12V/1.5A)
Product Dimension (W:122 mm x H: 33mm x L:216 mm)

I bought this item on eBay via buy it now from Envizage Solutions Ltd for £90.00. It’s been 2 ½ months since I bought the item and it has worked perfectly fine till now. I am currently abroad in Sri-Lanka and took the drive to my friends house so I could copy some of his files and as in Sri-Lanka they use a three pin connection I used an adapter for the square pin plug provided with the drive at his house. The hard drive was recognized and we were able to access the files and he was copying the hard drive’s files to his pc when all of a sudden an error message was displayed saying that the files cannot be copied stating something to the effect of ‘The data source is corrupted’. We thought it was just some random error and disconnected the hard drive and tried reconnecting but the computer would seem to try to access it but be unable to.

What exactly happens is when the device is turned on that the blue light in front of the external enclosure which is I think equivalent to the hard disk light on a normal CPU flashes but then goes off immediately, then maybe after a minute the light comes back on and goes off again immediately. As a result the hard disk does not appear on the computer as normal, as soon as the drive is turned on the sound which Windows plays when a USB device is connected is heard, however it is not accompanied by the usual auto play of the drive asking me what I want to do. Going to ‘My Computer’ does not even show the drive. I tried restarting the computer with the device on and Windows was stuck on the ‘Windows Is Starting Up Screen’.

I tried using device manager and through it, it insists the device is working properly. I even tried the USB troubleshooter Windows help but it did not help

If I go to ‘Safely Remove Hardware’ option the drive is listed as mass storage device Maxtor 6 L200P0 USB Device. When I try to stop it at first it says that it cannot allow the action as the computer is accessing it, but later it will allow me to remove the device safely from the computer.

Then after the device has been turned off the following message is displayed
“Windows was unable to save all the data for the file I: The data has been lost. This error has been caused by a failure of your computer hardware or network connection. Please try to save the file elsewhere.”

I felt the hard disk drive and it is not hot as usual, please bear in mind I have tried it at both my friends and my own computer.

I appreciate any help provided which can help identify what the exact problem is, I sincerely hope that the 200gb hard drive isn’t fried as I used this as my backup and all my photos,music,video and important university stuff is stored on it. Please help!

  MichelleC 13:28 31 Aug 2005

What happens if you hook it up as a slave in the tower?

  [email protected]!nD 18:41 31 Aug 2005

hi thanks for getting back to me, its an external so im not sure how to do that, and i dont want to risk loosing my guarantee by opening it,ive emailed them theyve asked if i can send it for insepection, what do u guys advise i should do cos i could get someone over in srilanka where i am at the moment to do so ut i guess that would void my guarantee

  Fruit Bat /\0/\ 20:03 31 Aug 2005

I am currently abroad in Sri-Lanka and took the drive to my friends house so I could copy some of his files and as in Sri-Lanka they use a three pin connection I used an adapter for the square pin plug provided with the drive at his house.

Voltage supply in Sri-Lanka is?

Sounds like power supply in external HDD is defunct.

  [email protected]!nD 19:08 01 Sep 2005

hi I'm pretty sure its 250v, theyve suggested i take the drive out and plug it in to my tower although I'm not sure how to do that I would appreciate some help on how i can assign it to slave and the pluggin in bit

  Fruit Bat /\0/\ 20:14 01 Sep 2005

When you open the enclosure (powered off )the HDD will be held in by 4 screws. There will be a IDE cable(ribbon) and a powercable (D plug 4 wires) in the back of the drive, these run from a small circuit board at the rear of the enclosure.

Carefully undo the cables from the drive and remove the screws. the drive can now be lifted clear.

At the rear of the drive, between where the cables plugged in, will be a nother set of pins with maybe a couple short together by a little plastic plug. This is the master slave jumper setting, should be shown where the plug fits on a label on the drive. It will be set to master for use in the enclosure. You need to change to slave for use in your tower.

With tower switched off. Remove cover from tower you will see same arrangement for your HDD but the ribbon cable should have a spare connector halfway along its length.

Plug the drive into this connect a spare (D) power plug.

boot your PC and it should detect the drive as slave on the POST screen and it should show up in My computer or Explorer.

  Fruit Bat /\0/\ 20:14 01 Sep 2005
  [email protected]!nD 18:54 08 Sep 2005

my hard disk isnt even detected when i plug it internally and it has been put to the jumper setting, system is really slow when the drive is plugged in and my computer shows it as local disk but cant access it :(

  [email protected]!nD 18:42 09 Sep 2005


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?