Maxthon

  [email protected]? 20:53 15 Nov 2005
Locked

I am using Maxthon as my default browser as it was recommended to me as an excellant pop-up blocker. The only problem is is that when I open it it comes up with the Maxthon Start Page rather than the website I want as my 'homepage'. Any ideas how I can rectify this?

  [email protected]? 21:10 15 Nov 2005

Solved it myself!! Should anyone else need to know, click on desired homepage select options>maxthon options>general tab>start page on left>use current.

  zincy 21:51 15 Nov 2005

i too use maxthon and find it lot easier to manage compared to IE when opening many windows

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

See the Best Button Badge Designs of 2017

iPhone X review

Black Friday 2017 : date, sites participants & bonnes affaires