Loud CLICK on Sony Vaio VGN-FS315E PCG-7D1M. Now w

  danielgent 13:37 17 Nov 2009

Hi there,
I've got a Sony Vaio VGN-FS315E PCG-7D1M laptop here. The owner says that she lost the original charger and once tried to force in the wrong charger (not realising the different ends are to stop you plugging the wrong voltage adaptor in!). Not sure whether the charger she forced in was over or under volting but she said that there was a loud click sound (not sure whether windows booted) and then the laptop wouldn't work.

I had a look at the laptop at my house and connected my universal adaptor. It had the correct adaptor and an LED readout showing the correct voltage (19.5V).
The AC power lights turned on and the laptop booted up. It got to the logon screen and I left it there while doing other work on another computer. I heard a loud click sound. Now the laptop won't turn on, the LEDs on the front do nothing if the AC power cable is plugged in.

Has anyone experience of this and what the loud click could be? I tried removing the battery and holding the power button down for ages but to no luck. Is it worth me taking the laptop apart and getting a voltmeter on it? I don't think it'll be anything as simple as a cracked joint soldering the DC jack in....but always worth a look.

I had a look on ebay for a replacement motherboard but either there aren't any or I need to strip the laptop down to read off the proper motherboard name (rather than search by laptop model).

Any help would be much appreciated!

Dan Gent

  rawprawn 13:46 17 Nov 2009

You may be better posting a thread here.
click here

  danielgent 14:57 17 Nov 2009

thanks, just posted it on there now

  danielgent 16:07 18 Nov 2009

no reply yet from that forum.

Took out all the components, still no lights come and it doesnt power up.
The DC jack is attached to the mobo by a cable so it looks like this
click here
a clever idea as it speeds replacement but it costs loads. I think I could get one of these though and solder it on the end of the existing cable
click here

The DC jack is cracked a little. Not sure if thats why its broke but I got a voltmeter out, my universal adaptor is giving out 19.5V but no matter where I attached the two metal probes (is that the right word?) I couldn't read any voltage (with the adaptor plugged into it and the cable connected to the mobo).

Is it quite easy to check that a voltage is coming through the DC jack?

  woodchip 16:33 18 Nov 2009

Click may have been Hard drive, Try starting in safe mode tapping F5 as computer starts in safe Mode try doing a System Restore to a Older Date

  danielgent 17:02 18 Nov 2009

Quoting my original post
"Now the laptop won't turn on, the LEDs on the front do nothing if the AC power cable is plugged in."

  woodchip 18:08 18 Nov 2009

Will it turn on just with battery in, or battery out and just on mains?

  T0SH 19:12 18 Nov 2009

If it booted to the welcome screen then emitted a loud click then I would be suspecting a hardrive head crash made the loud click

You could try removing it then powering up the laptop and tapping on the F2 key to enter bios setup ,if you get there and can stay there for a while good and well a new hard drive and a restore disc will get it running again

failing that it is probably not worth fixing

also have you checked the output of your universal adaptor with another laptop ? does it still work ?

Cheers HC

  danielgent 09:36 19 Nov 2009

It won't turn on at all woodchip. no combination of AC power and battery make a difference. no lights, no fans, nothing.

previously on the loud click it got all the way to the windows login screen (where i left it for about 20 minutes). then the loud click and now nothing.

Checked the continuity on the DC jack using a multimeter and its fine. the problems the motherboard. I took the whole thing out to look at it but can't see anything blown (wheres no big capacitors like on PC motherboards) so not sure what to do next. Look for a new motherboard I suppose!

  danielgent 09:37 19 Nov 2009

to T0SH - yeh the universal adaptors still working. i tested it with the multimeter and it was outputting a nice 19.5V. I'll stick it into another laptop now though to be sure.

  danielgent 09:59 19 Nov 2009

yes the universal adaptor does work. so its definitely not that.

Looked for a replacement motherboard for the broken one with serial A1142569A
click here
so think I'm going to get this and hope that fixes it! only a 30 day warranty though...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache