lost HDD capacity

  Bob17 23:37 03 Aug 2005

Used MBRwork utility to format an IBM 61GB deskstar HDD. Probably also altered EMBR to zero at same time, (was trying to remove a conflicting o/s). Now see only 32 GB of 61GB capacity. Tried NTFS, FAT32, Partition Magic etc. Is there an IBM equivalent too to Seagate Disk Wizard. Otherwise any suggestions please ?

  Peter 23:57 03 Aug 2005


Could be a setting in the BIOS needs to be altered or perhaps it's an OS limitation.

Have you tried FDISK?


  DieSse 00:07 04 Aug 2005

MBRWork does not say it does formatting!

Try using it to set the mbr to a standard value rather than all zeroes.

  Bob17 12:15 08 Aug 2005

Agree mbrwork does list formatting as such but when all fails setting the MBR to zero does result in a clean HDD. (my problem - a little knowledge is a dangerous thing) Still how do I recover the missing 31 GB?

  Bob17 12:22 08 Aug 2005

Yes, Peter, tried fdisk, that also shows only the 31 GB.
When working with a Seagate HDD, have found the Diskwizard too very useful, but this does nothing for an IBM drive, and was hoping somebody could provide a pointer to a suitable IBM tool/utility.
Thanks Bob 17

  pk470 13:20 08 Aug 2005

Don't know if this will work in your case but worked in mine insert W98 or WME floppy in and boot up on the prompt choose without CD Rom support on the A:\ PROMPT type FDISK then choose delete none dos partition delete the Prime DOS partition if your running W98 or WME then you will have to create a DOS partition then make it active then format if your running W2000 or WXP then all you do is insert the OS disks and this will partition and format for you.

  pj123 13:39 08 Aug 2005

I have a floppy disk (from years ago) called Ontrack Disk Manager, which I have never used but looking here:

click here

it seems it will do what you want. Doesn't appear to be free though.

  pj123 15:42 08 Aug 2005

email me if you would like a copy of this. It is dated 1994 so can't guarantee it will work. As it contains .exe files I have zipped it up so you will need an unzipper.

  DieSse 15:57 08 Aug 2005

IBM drives are now owned and supported by Hitachi - support/downloads page here. click here

I suggest you look at the drive fitness tests to see if you can reset your drive to "as was" status. I think zeroing the mbr will make it look odd - there should be information in the mbr relating to the partions.

If your drive is limited to 32Gb - this may be by your system - some BIOSs have this limitation - it could be that you had software installed on the drve to "fool" the BIOS. The On-track disk manager can do this - but I would stay well away from a version as old as 1994 personally.

Unfortunately Hitachi no longer seem to supply software to resolve this capacity issue (whereas Seagate and Maxtor do.) You could buy the current version of On-track click here

Hope some of this points you in a useful direction.

  Bob17 23:35 21 Aug 2005

Tried this as suggested. Used the Utilities to set the MBR to zeros and then also the disk. Result is still only 32,247.6GB visible. Tried both Fdisk and Partition Magic to see if they would show the missing portion - no luck.
Is there something earlier, such as the EMBR which has details of the HDD model with its capacity that I have corrupted ?

  DieSse 23:50 21 Aug 2005

In your "messing about (;-))" you haven't accidentally put a capacity limiting jumper on by mistake? - This would definately make the drive look as though it had only 32Gb come what may.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?