Lost DVD drive on laptop

  oak chip 22:22 13 Sep 2007

Over the last 2 months my DVD/RW drive on my laptop keeps dissappearing. I have tried scans on malware (Spybot & AdAware), virus scans (AVG free),Rootkit scans (AVG again), and System Restore. All have produced some (temporary) result, but no permanent solution. The drive open tab also fails to work, and the tray can only be opened by the emergency release hole & a paper clip end. 'My Computer' and 'Device Manager' do not show the drive, or aknowledge it exists. Looking at the Windows XP fault log reveals a variety of errors. "The device 'TSSTcorp CD/DVDW SN-S082D' (IDE\CdromTSSTCorp_CD/DVDW_SN-S082D_SS02_\5&17b1fe77&0&0.0.0) disappeared from the system without first being prepared for removal". This message was tabbed under the 'PlugPlay Manager' The machine is still under warranty, so I am reluctant to open the case (even if I knew what to look for!! Is this likley to be a faulty unit, loose cable, or what?? (The prolem seems to occur after the machine has been on for some time, has 'gone to sleep' and been 'woken up' again. All ideas gratefully received

  skidzy 22:23 13 Sep 2007

Missing cd/dvd drives can be normally associated with the removal of burning software such as Nero/Roxio/Sonic/Easy CD Creator etc.
And not showing the drive in My Computer.

Firstly try resetting the DMA settings incase PIO has been selected over DMA click here

Try the below link ,if still no luck follow the Procedure of removing the upper and lower filters.

Reset the cd/dvd drives in Windows Explorer using the below tool from Doug Knox

click here

If no joy with the above fix,try the Microsoft Guided Help

click here scroll down to the Guided help download and follow the instructions.

If still no joy,follow the manual fix below.

If you have further any error codes,please post them.

Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code:
Code 19, Code 31, Code 32, Code 39, or Code 41
, delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key ( if Vista Start search or windows+R )
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

.If in any doubt editing the registry,please create a System Restore point first and also backup your registry....The guidedhelp from Microsoft on backing up the registry is a good lesson for anyone to learn. click here

Creating a System Restore point:

Start/All Programs/Accessories/System Tools/System Restore…follow the prompts.

  skidzy 22:24 13 Sep 2007

Try the second link first

  oak chip 17:49 14 Sep 2007

skidzy - Thanks for your reply - I did try the first fix from Doug Knox, as I had searched the forums for same/similar problems before posting my query. No luck!! I am reluctant to try the second fix as the machine is still under warranty. I have removed no files or programs around the time the problem started. (I have removed no programs around that time) It looks as though it will have to go back to the firm that sold it under warranty!!

  oak chip 18:15 14 Sep 2007

Further thoughts - when the machine is first switched on, the drive is there, and works fine, but after about 30/40 minutes - as the machine warms up - it disappears!!

  skidzy 19:45 14 Sep 2007

Then i would say its faulty oak chip.As the machine is new,send it back.

The second fix is quite safe providing you follow the instructions to the letter.
Sometimes you may only see one of the filters,either upper or lower.
If they exist,try deleting one at a time and reboot.

If you are concerned of editing the registry,back the registry up first.

  oak chip 20:23 18 Sep 2007

As it is still under warranty - I have decided to take it back to the shop. Thanks for all your help - much appreciated. I will post the result after I get it fixed/replaced!!

  Black Crow 17:23 24 Jun 2008

skidzy is right, I got the same problem with my laptop too , when i removed the Burning software. I followed your instruction to delete the lowerfilter from the registerkey and it work well.......
just to say thank you..

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

5 best 3D model websites

iPhone 8 vs iPhone X

WhatsApp : comment lire vos messages sans que l’expéditeur le sache