Losing printer connection with photo printing.

  New silver surfer 16:01 11 Mar 2005

My Canon printer keeps stopping when attempting to print photos - "Spooler SubSystem App has encountered a problem and needs to close" is the message which comes up. Then I cannot get anything more to print - it tells me there is one document pending, but checking on the printer nothing is shown in the queue. And trying to print again the computer tells me that no printer is connected, even though the printer is shown as active! The only way to reactivate it is by turning off the computer and then turning it on again - even re-booting doesn't enable the printer to be used again. I have never been able to send more than one document at a time to the printer without this Spooler Subsystem App report coming up, but got round it by just sending one thing at a time: but now that I have just started trying to print photos, each time I try a photo on photo paper I fail. However on re-starting the computer I still seem to be able to print documents. If I insert a photo into a Word document then I haven't encountered a problem.

Has anybody got any suggestions please. They need to be very basic instructions as I am not very computer literate. Would welcome any advice.

  john-232317 17:50 11 Mar 2005

Sounds like driver problem.

Has it worked before ?

Did you install the software as instructions ?

Canons site for latest drivers click here

Scroll down till you see your printer, I assume you are on XP.

  Dorsai 19:03 11 Mar 2005

My epson (I know, perhaps not relevent, as yours is HP) developed a similar fault, and would print B&W fine, but in colour it would do about 2cm, then stop. After a few seconds XP would report that the printer was not responding.

I fixed the problem in the short term but replacing the USB cable with a parrallal cable. Then next time i had the weekend off took the printer back under warranty. The exact model I had was no longer avaliable, strange, as it had only been out for about a year......I got one that looked exactly the same, same spec, same everything, but with a model number 2 higher....I guess the printers were all duff...So they fixed the fault, and re-badged it so that the 'new and improved' model would not suffer from the reputation of the old....

I woudl start by ininstalling the printer drivers, and re-installibng them. If that does not fix, try uninstalling the printer drivers and the USB drivers. then reinstall..

Also try the printer on another USB port, or ideally another PC.

  Dorsai 19:03 11 Mar 2005

HP, D'OH, Cannon........

  FelixTCat 19:06 11 Mar 2005

It would help if you tell us a little bit about your computer. Are you running Windows 98 or XP? How much memory does the computer have?

  john-232317 19:08 11 Mar 2005

Looks like brother printers had a similar problem ,same error code, but have a patch to cure it.

  john-232317 19:10 11 Mar 2005

Forgot the link click here

  New silver surfer 16:41 22 Mar 2005

Thanks for the suggestions, sorry its taken a while to get back to you. I do appreciate the help that has been offered. I did what you suggested dadyassa and looked up the drivers for Canon. Unfortunately my printer - a Bubble Jet S630 - was not listed, but it gave me the idea to try to contact Canon for some help. Unfortunately I haven't had any response from them, even though I have sent a "chase up" e-mail. So I am not impressed with them.

I had previously unstalled and them re-installed the printer - but this didn't solve the problem. As I keep getting a message about the Spooler Sub System, I went into the printer properties and unchecked spooling, and checked print direct. This doesn't seem to have helped, because even though I am printing direct, I still get the same message up!!

I don't think I will be able to get a new printer under warranty, as I have had the printer for 3 years now. This particular problem is only just showing up because I have just started with digital photos.

I have got XP Home edition, plus Word 2002, and the odd thing is that if I create a Word document and insert a photo within the document, then there is no problem in printing it.

Any suggestions?

  FelixTCat 16:54 22 Mar 2005

Go to this site: click here and click the drop-down box for printers. The S630 is about 3/4 down. Click on it.

In the next window, scroll down to "22. Canon BJ Windows 2000/XP Printer Driver for S630 (WHQL) (1.50) " (about 1/3 way down).

Click on that and you can download the driver.

See if that driver helps.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Comment créer un compte PayPal pour payer en ligne ?