losing connection to hard drive

  paulwd 12:42 17 Jan 2005

Have 2 hd's, up to last week would lose f (storage hd) every day, rectified by unplugging and replugging ribbon cables, checked cables by replacing with another set, same problem. Replaced f drive with brand new unit. Worked fine 2 days, now twice in last twelve hours has lost both drives c(master) and new f (storage/slave). When reboot pc says primary and slave drive not detected. Turn off and back on after unplugging all three plugs on ribbon cable (which are good snug fit)and plugging back in normally detects them again. If it's not cable or hdd's at fault what's it likely to be as I am loathe to keep shelling out more money without knowing if that will cure it

  alan227 13:05 17 Jan 2005

Can you try these two drives in another computer?.
It sounds like a dodgy IDE controller or a virus.
Have you got an up to date virus scanner, if not run an online one here.
click here

  paulwd 13:24 17 Jan 2005

Hi, yeah am up to date with anti virus, use avg and haven't detected any nasties, by ide controller you mean the controller on the mother board? Unable to put drives on another pc as don't have access to another for diagnostics. Was angling more to hardware failure rather than virus as happens intermittently lie once every five or six hours, all of a sudden both go and won't be recognised when I reboot yet will when I disconnect and reconnect ribbon cables and then work perfectly fine until the disconnect again with no warning. The f drive is brand spanking new, previous to the instal on friday it lost the c drive once in two months but the old f drive either once or twice a day minimum, am I looking at a new board then

  seedie 13:34 17 Jan 2005

Sorry to say this but my money's on a bad solder connection where the ide skt sits on the MB or maybe unstable printed circuit track. Hope I'm wrong but if you can't substitute it may have to go to a repairer.
whatever-good luck


  alan227 13:37 17 Jan 2005

If you have tried other cables and the F drive is brand new and it is still happening then you have illiminated two possibilities.
Have you checked the settings in the BIOS.
Other than that it looks like the IDE controller is on the way out.
How old is the mobo?.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?