Logitech software problem

  m4819 07:02 04 Nov 2006
Locked

Whenever I try to install the itouch software for my keyboard I get an error that says "Sorry, this software is not compatible with your operating system. Your device will still provide basic functionality. The installer will now close." I use XP, I've tried installing it both with the included cd and with the software off the site. Has anyone else had this problem or know how to fix it?

  anskyber 09:42 04 Nov 2006

Is the software XP , sometimes software is only needed for win 98 or 2000. Sorry if its a daft question.

  [email protected] 11:10 04 Nov 2006

i bought logitech revolution a month ago and am impressed, i installed supplied software which added 2 processes cluttered desktop and the advantage was small, i have xp and everything seems to work fine without the logitech software, which i have now removed.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017