Logitech SetPoint 4: Missing Keyboard / mouse tab

  bsedito 18:38 13 Aug 2007
Locked

I saw many people had this problem when installing the 4.0 version of setpoint.. so I spent several hours playing around with the registry, system files, etc, to find that did nothing.. BUT I finally found the very stupid and very easy solution to this minor (must be) software flaw in 4.0

The mouse included with my Logitech DiNovo Cordless Desktop mice/keyboard combo decided to cease working, so rather than calling support, I did the next best thing, and dropped $200 on the DiNovo EDGE keyboard. Kudos to logitech on the EDGE, this is the best keyboard/peripheral I have ever owned.

Anyway, heres the background. Apparently SetPoint buries itself everywhere in your computer like a rabbit in heat, to the point where logitech needs to publish a "guide to do a clean install of setpoint" ..before you follow the below instructions, make sure you do that, even if you installed some sort of logitech setpoint years ago, chances are its still there lurking somewhere.

Finished uninstalling everything setpoint from your computer? Good. Now brace yourself for this stupid fix that places the "my keyboard" and/or "my mouse" tab(s) back into setpoint

This problem is caused by, at least from my observations, conflicting drivers between what the keyboard itself installs and what setpoint thinks it has. Thanks again, Logitech and microsoft. Here's the fix:

STEP 1:
Save these steps in Word or Notepad and restart your computer. After it reboots, right click "my computer" and open up the "device manager"

STEP 2:
Find the 'keyboards' tab in the device manager tree. (Or mice if it's the mouse tab missing, or both if both tabs are missing, and do the same with each step, depending on your situation)

STEP 3:
Right click 'logitech HID keyboard' and choose 'properties' ..(it may be something different but it looks like that, and HAS to say logitech.. if it doesnt email me and i can send you the fix for that stupid problem as well)

STEP 4:
select 'update driver' (make sure it can check the internet for drivers as well.. and make sure you choose the 'automatically' option

STEP 5:
Let it search until its done.. be patient here.. took about 5 minutes for it to finish for me at least

STEP 6:
there is no step 6, thats it, done, voila, like that.

My windows vista home edition premium told me I had to restart, I didnt even do that (i'm impatient).. the keyboard tab is now in setpoint and whoohoo I can finally customize the keys on my 200 dollar keyboard, and pay 5 times as much for hair transplant surgery after spending hours trying to fix this.


For those interested in what my system configuration is (I don't believe it really matters) here it is:

-IBM (Lenovo) ThinkPad T43 w/ biometrics coprocessor (fingerprint reader)
-Windows Vista Home Premium
- 1.5 GB of physical RAM
- 1.25 Terabits of HDD storage (yeah, excessive, I know) in 3 external drives and internal
- 12 USB ports, all used up (3 powered usb 2.0 hubs)
- External monitors
- Logitech's music system has been isntalled on it
- Logitech xbox 360 media center remotes has been installed

...on just a laptop, and it runs faster than my Intel Core 2 Duo desktop. how about that. I put that up just so people can get an idea of how many drivers and processes I have running on my system, and the fix still works


NOTE: Regardless if the fix works or not, post it! I am eager to find out if it worked, I want to help everyone out by sharing my experience, thanks, and good luck!

  Pterocarpous 21:03 10 Apr 2008

Hello bsedito

I'm writing in ref. to step (3) on your instructions. I don't know how to get your email address to email you a request for this but I'd sure like to know how to fix that issue. (Keyboard HID device is generic rather than Logitech - therefore cannot update keyboard HID driver per your instructions.)

Believe it or not, I'm an IT "specialist". 'Been in the field since the dark ages (DOS...). So, I know my way around pretty well. But I gotta tell ya, this problem has me climbing the walls. I finally broke down and called Logitec support this a.m. and spent more than an hour on the phone w/ the rep (who was very nice and courteous, btw) mostly repeating things I'd already tried (using what I'd found on forums like this - and your posts).

We got Setpoint back to providing a "My Mouse" tab again. Basically by renaming the wdf01000.sys file in ...\system32\drivers. (OS=XPPROSP2). I'd done this b4 but I uninstalled Setpoint b4 reinstalling it. When I tried this w/ the Logitec rep, I was instructed NOT to uninstall Setpoint 1st - rather install on top of it. So, I did and, lo' and behold, it worked - I got my "My Mouse" tab back.

In an effort to get the keyboard tab showing in Setpoint, I had uninstalled then re-installed (no cleanup, etc in between) the Setpoint software. After that, not only did I still have no "My Keyboard" tab in Setpoint but I'd lost the "My Mouse" tab as well.

I'd already had to restore an image of my hdd because, b4 this, I'd screwed around w/ Setpoint, dinkin' w/ files and the registry.... Well, it was a mess. So, restore was the next course of action. (Thank gods for ATI!) Then I begain again w/ the sequence of events I described previously.

Logitec swears up and down that there is no Logitec HID driver for the Alto wireless keyboard. That all the "special functions" marked on the keys are Industry standard key stroke combinations. Well, I beg to differ OR there's somethin' amiss on my system. I can't get any of these function key combinations to work. (e.g. FN + F1 should open explorer; FN + F2 should open the default email client; FN + F3 should open the default browser, etc. etc. None of them work.) Nor do the sound buttons work (increase and decrease volume and mute).

I'm convinced I need the Logitech HID driver for the keyboard. If I'm wrong, please, someone tell me. But tell me how to fix it, too, please, if you can...

So, my friend, if you could p-l-e-a-s-e send me that fix I would be ever so greatful!

Pterocarpous
[email protected]

  Technotiger 21:16 10 Apr 2008

Hi, it is not a good thing to show your email address in an open Forum. The Yellow envelope icon next to your name is there for the purpose of cross-communication between forum users - BUT only use the yellow envelope by Invitation of the 'owner'. No harm in asking for permission though.

  [email protected] 21:29 10 Apr 2008
  Pterocarpous 21:34 10 Apr 2008

Thankyou Technotiger. I agree. I'm just desperate to get this resolved.

I guess there's no way to go in and edit one's posts on this forum - or is there?

bsedito had asked that requests for instructions on the issue I spoke of be emailed to him.

How can I let him know I'd like to email him w/ this request (if the email to another user can be by invitation only...)?

Forgive my ignoance. I'm brand new to this forum.

Thank you in advance,
Ptero'

  Technotiger 21:39 10 Apr 2008

OK, you should click on his Yellow envelope, you will then be able to email him as he has made the request.

And no, it is not possible to edit Posts, not even your own.

The Forum rules can be downloaded by clicking on the Forum rules link above.

  dckrl 00:00 03 Jun 2008

Simply pulling out and re-inserting the receiver back into the USB port (with SetPoint up and running) did the trick for me. Having done it once, the MyMouse tab shows up ever hence.

My config is a Vista Premium Home SP1 / Hewlett Packard laptop / MX Revolution cordless mouse.

  I am Spartacus 10:45 22 Aug 2008

This is only my view but the Setpoint software wins an award for the flakiest most useless program ever written.

I have a DiNovo Edge keyboard and while it's very, very good the Setpoint software lets it down badly.

I use the Microsoft Intellipoint software to control the trackpad and it works very well. XP and Vista do recognise the sleep, speaker and Media Player buttons/sliders but not the function or zoom keys.

  dencar 23:04 28 Dec 2008

bsedito you are a genius and a gentleman. After hours of searching and frustration your fix provided the mouse tab to enable me to configure my Dell BT Travel Mouse. I have a Dell Inspiron 9400 running Windows XP SP3. This fix should be in lights on the Dell and Logitech sites. Thank you.
dencar

  Deerhaven 15:38 11 Feb 2009

Here's what just worked for me.
- Closed SetPoint
- Unplugged USB and Keyboard plug (PS2?)
- Started up Setpoint
- Plugged in just the USB (not the keyboard connection - I wonder if that's the problem).
- the machine took a minute or so to identify the new hardware.
- pushed the Connect button on the dongle and attached the keyboard.
- pushed again and attached mouse.
- Tabs are back with my settings.
Hope it works for some others.
J

  Will Gadsby 03:01 01 Feb 2010

Thanks, Pterocarpous -- I managed to get my Keyboard tab back in Setpoint 4.00, but no sign of the Mouse tab!!

Still, I'm much happier thanks to your help.

Will

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?