Linux-Suse 9.3 problem.

  dagwoood 14:19 15 Sep 2005

I did an internet install of Suse 9.3 but when I opened it, whenever I tried to do anything, my system would lock and I was forced to do a hard re-boot.

I thought it may have been a download error so I downloaded the CD iso files(all 5 of them!)and installed Suse this way.

Even after installing Suse via the CD method, I was getting the lock ups. Whenever I try to do anything on it, it still locked, i.e.can't scroll, close open windows, right click to bring up menus, perform updates, change system settings. I had to do a hard re-boot again to rectify this.

Something I noticed when the system was booting up was an error worded to the effect that my system may run slow as DMA isn't enabled, which leads me to think that it's a RAM issue.

Now, to get windows to run stable with my m/b chipset, I have to manually set my RAM timings(a known issue with nforce2 chipsets). I set the CAS# latency to 2.5(my memory latency should be 3.0 at 400MHz). I'm also running in dual channel mode.

Could either of these be the cause of the problem when trying to run Suse? I have 1.5GB of RAM in my system, does Linux not like this amount of memory? Or am I barking up the wrong tree?

My system comprises Athlon XP 3200+, 1.5GB RAM, Geforce 6600GT AGP, 120GB Barracuda(8MB), 40GB WD(2MB), Gigabyte GA-7N400-L.

The main reason I chose Suse is that I'm a complete newbie when it comes to Linux. I installed Linspire but the graphics were, well, crap. But I was having difficulties in trying to get the Nvidia driver to install. Suse, however, is an easier platform to use to install s/w.

Cheers, dagwoood.

  Yoda Knight 14:22 15 Sep 2005

Dunno about the problem, but Xandros is even easier for newbies

  Chegs ® 14:31 15 Sep 2005

I would dig around in your RAM timings,as I have 1.5Gb RAM and Suse 9.3 was running flawlessly on SATA with AMD 2,700 CPU,it picked up my "obsolete" hardware[scanner](XP bitched about it)and apart from Linux refusing to do anything with NTFS partitions(I couldn't do anything with the NVidia driver d/l'ed to Win partition)it was fun to poke around in Suse.

  woodchip 14:35 15 Sep 2005

DMA can be enabled in BIOS

  dagwoood 16:25 15 Sep 2005

Yoda Knight, I'm downloading that as we speak. I'll give it a try if I can't sort this Suse problem out.

Chegs ®, thanks for that; at least I know it's not related to the amount of RAM I have.

woodchip, the only DMA settings I can see in my BIOS relate to my h/d's and they can only be set to auto or disabled. My first thought when I saw the DMA error was it was some sort of h/d error, so I ran CHKDSK and Seatools, but there they didn't find anything wrong physically with the disk.

Seatools threw up one error, "One or more errors were found in metadata file records". As this relates to the drive has a whole(not specifically the C: partition), and windows runs fine and CHKDSK didn't show any errors, I put the error message down to some foible of having Acronis True Image installed. I know this modifies the MBR if you turn the Acronis secure zone on.

  Buachaill Mor 16:27 15 Sep 2005

One more reason to stick with Windows ;-)

  octal 17:50 15 Sep 2005

Buachaill Mor

Lucky everyone doesn't think like you, otherwise there would be no competition :-)

  Diodorus Siculus 18:38 15 Sep 2005

octal - little in the way of competition anyway.

I'm a fan of Suse and like 9.3 a lot. Don't know what's wrong with dagwood's though. There can be so many problems with hardware incompatibilities it is next to impossible to work it out at times.

  Chegs ® 18:47 15 Sep 2005

"I put the error message down to some foible of having Acronis True Image installed."

I found TI(I have it to)decided to "throw in the towel" when I put Suse onto my PC.None of the images I had created prior to Suse install would reload,updating these images was forever producing errors,unreadable images(even my known good image refused to reload)I was fortunate in having DriveImages in addition to the TI images,as (touch massive forests) these have never let me down,even after "losing" them in a catastrophic screw up caused by me with a weedy 98se boot floppy that removed all partitions from my drives,and recovering the DI images with a recovery app.

  octal 18:51 15 Sep 2005

When you mentioned the possible problems with nforce2 chipsets I did a quick Google and you are right there are problems with Linux click here so I suspect no matter which distribution you use the problem is with the Kernel and not the distro.

There appears to be a work round on that site, it may work for you.

  dagwoood 19:02 15 Sep 2005

I found out that when Suse throws a "wobbler" it can really put a spanner in the works with regards to running windows and Linux on the same h/d(obviously on different partitions).

After a hard re-boot, all Suse would do was load so far then stop at X console with a floppy drive error message. It then wouldn't let me into windows and when I put my XP CD in to get to recovery console(to run FIXMBR)nothing happened, my screen remained blank!

I got round this be restoring a drive image using TI, but copied the image to the WHOLE of C:. I lost Suse but at least I had windows up an running.

Acronis TI has saved me a LOT of work over the past few days.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?