Linksys WAG54GX2 not recognising my ISP

  ashwat 12:17 02 Sep 2006
Locked

My objective is to set up a wireless connection to enable me to move a PC from downstairs to upstairs, where there is no telephone access point.

I have purchased a Linksys WAG54GX2 ADSL Gateway and Linsksys WUSB54GS adapter to enable me to achieve this objective, and the adapter sends a signal to the Gateway, but the Gateway doesn't recognise my ISP, which is Plusnet.

Using the installation CD that comes with the WAG54GX2, I am able to input the settings that apply to my Plusnet account:

VPI = 0, VCI = 38, PPPoA, VC Multiplexed

but when the Gateway trys to detect my ISP I get the following error message:

“Unable to detect the internet connection. Please go to the advanced settings page and check your internet connection type.”

As a non-technical person, this is where I’m getting confused. I’ve adjusted Internet Explorer settings so that they don’t default to a dial-up connection. Other than that, I’m not sure what needs doing to get my ISP settings recognised. I should explain that I use Mozilla as my preferred browser.

I’ve therefore been unable to get to the point where I am required to access the web-based utility by inputting the Gateway’s default IP address into the browser.

The Linksys user guide, and ISP advice, both suggest that a dynamic IP setting should allow the adapter to communicate with the Gateway. I receive a “limited or no connectivity” error message when I use this setting, but no such error message if I use a static IP address with the adapter. Pinging 192.168.1.1 does not generate a reply, which indicates that the PC is not communicating properly with the Gateway. I’m reasonably confident that all cables are correctly inserted.

After reading advice offered to others, I disabled security settings in both the Gateway and adapter, and disabled my software firewall, Kerio.

Can anyone suggest something further I could try to get my ISP recognised by the Gateway?

Also, can anyone suggest why “Obtain an IP address automatically” is not resulting in the adapter communicating with the Gateway?

Thanks in advance for any advice.

  FelixTCat 13:41 02 Sep 2006

ashwat,

Firstly, thank you for providing so much information.

I suggest that you approach this problem in 2 stages:

1. establish the internet connection.

2. establish the wireless connection.

To establish the internet connection, set up the gateway at the phone point through a microfilter and connect your pc to the gateway by ethernet cable. Log into the gateway and put your ISP username and password in the broadband set up page. Save the settings if necessary (some routers save automatically).

Check the gateway's network IP address (it will be something like 192.168.1.1) and set the DHCP server to issue addresses in the range 192.168.1.3 - 192.168.1.9 (the first 3 sets of numbers should be the same as the first 3 sets of the gateway's IP address).

On the pc, go into the TCP/IP properties of the network connection and tell it to obtain an IP address and a DNS address automatically.

Open a cmd window (Start - Run, type cmd [Enter]) and type ipconfig /release [Enter], then ipconfig /renew [Enter].

Now check to see if you have an internet connection. If you have, set your gateway's firewall and your pc's firewall. Make sure that the pc's firewall will allow the IP address range you set in the gateway.

Once that is working, you can set up the wireless network. I suggest that you do this close to the gateway so that you can reconnect by ethernet if something goes wrong.

Make sure that the wireless part of the gateway is switched on in the setup pages and set the SSID (the wireless network name) to something you will recognise. Disable any encryption.

Disconnect the ethernet cable, install the wireless drivers and attach the wireless adapter to the pc. Again, set the TCP/IP properties of the wireless adapter to obtain an IP address and DNS server address automatically. The adapter software should show the wireless networks that it has detected by SSID. Highlight yours and click Connect. After a short while the adapter should log on to the gateway and obtain an IP address. You should now be able to access the internet wirelessly.

Now you can consider protecting the wireless network, but get this far first.

Regards,

Felix

  ade.h 13:42 02 Sep 2006

You need to set it up manually from within the config with Linksys routers that do not recognise your ISP. Your ISP parameters are correct for UK ADSL, so just enter them into a new WAN connection in the config, not with the CD.

You should never disable Kerio, by the way. Otherwise, it cannot give you the rule pop-up when a new connection is made or access is attempted.

You'll need this soon so I might as well post it now: click here

We'll move on to correct adapter setup in due course.

  ashwat 19:35 03 Sep 2006

Thanks for the advice.

I'm now able to access the WAG54GX2 configuration pages and that has enabled me to set the DHCP server to issue IP addresses in the range suggested. The part of the gateway's status page that relates to LAN settings confirms this.

The LAN is now set to obtain an IP address and DNS address automatically.

When I ping 192.168.1.1 I am now getting replies, which wasn't the case previously.

However, after trying ipconfig/release and ipconfig/renew I don't have a wired internet connection.

I realise that I need to get over this hurdle before attempting a wireless internet connection.

The gateway's status page is not showing any ISP IP and DNS address information, and I don't know how to get the gateway to detect this information. Any further ideas?

  FelixTCat 13:28 04 Sep 2006

ashwat,

Have you set your pc's firewall to allow the IP range 192.168.1.1 - 192.168.1.9 (or 192.168.1.0, subnet mask 255.255.255.0)?

Regards,

Felix

  ashwat 21:08 04 Sep 2006

The 'trusted area' on my Kerio firewall now has both the IP range and IP/subnet mask combination registered against the LAN.

Unfortunately that hasn't resulted in a breakthrough.

The status page in the WAG54GX2 configuration shows the following settings against the LAN:

MAC Address: 00:14:BF:63:69:D9
IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0
DHCP Server: Enable
Start IP Address: 192.168.1.3
End IP Address: 192.168.1.9

and the following settings against the gateway:

Firmware Version: V1.00.01
MAC Address: 00:14:BF:63:69:DB
Current Time: 1970-01-01 01:25:51

Internet Connection
Login Type RFC 2364 PPPoA
Interface: Down
IP Address: ---
Subnet Mask: ---
Default Gateway: ---
DNS1: ---
DNS2: ---
DNS3: ---

Is there anything else that might be preventing the gateway from detecting my ISP settings?

  ade.h 21:43 04 Sep 2006

Your firewall rule is fine at least. I know Kerio very well - excellent firewall - and it's very tolerant of IP rules. You can actually use a starting IP and it will intelligently work out a range beyond that.

Just check that you haven't accidentally removed the Loopback entry above it, though.

  ashwat 22:16 04 Sep 2006

I've double checked the firewall, and I haven't done anything to compromise the Loopback entry.

  FelixTCat 23:34 04 Sep 2006

ashwat,

Clearly, you can access the router's setup pages now. In those setup pages have you entered the username and password for Plusnet?

In those setup pages there will be a page that gives you various details about the adsl connection to the router; things such as Downstream Rate, Signal to Noise Ratio, Attenuation. Please try to find that page and copy some of the figures here.

Regards,

Felix

  ashwat 00:43 05 Sep 2006

Thanks again for your continued assistance. Much appreciated.

I can access the set-up pages, and I have entered the username and password for Plusnet, as confirmed with Plusnet.

There are a number of status pages available for the gateway, and the one for DSL connection mentions the downstream rate, though I can't find anything that refers to Signal to Noise ratio or attentuation.

The DSL status page shows the following settings:

DSL Connection
Status: Up
Downstream Rate: 4960 Kbps
Upstream Rate: 448 Kbps

PVC Connection
Encapsulation: RFC 2364 PPPoA
Multiplexing: VC
Qos: UBR
Pcr Rate:
Scr Rate:
Autodetect: Enable
VPI: 0
VCI: 38
Enable: 1
PVC Status: Up

Does that offer any clues, or do I need to look elsewhere?

  FelixTCat 08:52 05 Sep 2006

ashwat,

Thanks for that info. The downstream rate of 4960 means that your phone line has adsl and the modem has recognised it and synchronised it.

It would appear that the reason that you are not getting internet access is that your modem, although synchronising with the adsl signal, is not logging on to Plusnet. It is absolutely vital that you enter the Plusnet username and password EXACTLY as given to you. It is case-sensitive, so upper case letters must be entered in upper case and v.v.

Do check that the modem is set to make the connection automatically - there may be an "On Demand" or similar box which should be blank. The always on option may be called something like Set Route.

If this still doesn't work, then I am lost for ideas, because this is the only step left to make a broadband connection. It is always possible that the router is faulty. Do you have a friend or colleague with broadband who could try it on his system (using his username and password)?

Regards,

Felix

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017