Linksys WAG54GS suddenly can't connect wirelessly

  Angus G 08:55 26 Jun 2009

I have a Linksys WAG54GS which has been set up and connected to a Mac via ethernet and wirelessly to 2 Mac laptops and 1 PC laptop for almost 3 years without issue. Suddenly yesterday morning, the laptops (all of them) couldn't access the internet and after re-booting the gateway, the 'internet' light on the WAG54GS turned red.

I connected to the setup utility via the IP and all of my gateway settings appeared to have been wiped. I did however have a back up as I had taken screen shots of every page of the set up utility with all passwords etc. written down. So I re-entered all of the settings as they were previously. The 'internet' indicator on the router turned back to green and all of the laptops could once again pick up the wireless router BUT none of them can access the internet.

The PC laptop sees the router, connects to it then displays a message saying that the 'network did not assign a network address to the computer' and it can't then connect to the internet (selecting the 'repair' option doesn't work). The MAC laptops see the wireless router, connect to it successfully, show a good signal strength but then can't connect to the internet.

Since the settings are exactly as they have been for the last 3 years and have worked day in day out without issue, it makes no sense - it is driving me mad!

I called BT first (although given that I have internet access through the router to 1 computer via ethernet, I didn't think the problem was with the ISP). They confirmed that the broadband line was OK.

I set up the router again, entering all of the information as it had been previously, rebooted the router, rebooted all of the laptops - same problem. All can see the router but cannot access the internet.

I then looked at various threads and began turning off things on the router like the WEP security, firewall etc. (despite these all working before) - same problem.

I've tried the Linksys online help - nothing there covers this issue.

I even decided last night that it must be the router hardware and so purchased a new router (Linksys Wireless N ultra range plus). That's even worse - I can't even get a wired internet connection through it.

Please if anyone can help - this is driving me insane!

  Taff™ 13:54 28 Jun 2009

Have you checked that the router has DHCP enabled? Also I would change the ADSL filter.

  Angus G 13:14 29 Jun 2009

Thanks for this - yes DHCP was enabled. I replaced the ADSL filter too. Curiously, I tried the Linksys Wireless N router again on Friday evening and this time an internet connection was detected and I once again have wireless internet access across all laptops and iPhones etc. I did nothing differently to what I'd done the day before - I can only assume that the WAG54GS had in fact failed (it was almost 3 years old) and that there was some legacy data issue when I attempted to install the replacement the first time around.

All working via the new router now but thanks very much for your response.

  Taff™ 23:33 29 Jun 2009

The common factor might be that you changed the ADSL filter - no matter! Almost 3 years old is nothing - Plug it back in and press the factory reset button for 30 seconds, then set it back up again manually. If it works put it away as a spare. The N router is better but somewhere along the line someone could use the old one!

Either way click and tick resolved.

  Angus G 23:46 29 Jun 2009

Thanks for the advice Taff, much appreciated.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?