Linksys router not assigning IP address

  01chris 13:15 26 Dec 2005

For christmas I got a Linksys WAG354G wireless router. I set it up and it was sharing internet over my wired network fine. I then tried to setup the wireless network and when I tried to connect my computers to that they would not get an Ip address from the router. (I have made sure they are set to get an Ip automatically). I then disabled the WEP security and they all connected fine.

Why does it not assign an Ip address with security enabled?

The wired desktop and one wireless laptop are Xp Home SP2 and the other wireless laptop is Xp Pro Sp2

(I have tried using a static Ip but the router wont talk to the computers then)

  LastChip 16:14 26 Dec 2005

All devices (including the computers) need the same key. Did you put the appropriate key on your computers? click here about a third of the way down.

  01chris 16:51 26 Dec 2005

Yep, all devices have the same key. I take it I am going about this the right way.

I put in the passphrase on the router ( for this example i will use watch as the phrase) and clicked generate on the router, it shows me 4 different codes (which I am not sure what to do with). When my laptops pick up the wireless network I try to connect to it using the SP2 Wireless network viewer thing and when it asks me for the key I put in watch. After that it trys to get an Ip address for about 50 seconds or so then it tells me that there is limited or no connectivity.

  LastChip 17:24 26 Dec 2005

It seems you may not be able to use a pass-phrase in Windows XP, though I can't work out what they mean by Zero Configuration.

You could try inventing your own hexadecimal key and manually entering it, for example 10ffe63da0, which is all a hexadecimal key is.

Until you have this working properly, turn off all firewalls and physically disconnect the device from the Internet, while your playing with the settings. Once you have the network working properly, introduce the Router firewall first and re-check and then any software firewalls, one at a time.

  01chris 10:15 27 Dec 2005

After playing around I discovered that you do not use the passphrase on the laptops but the funny codes the router generates.

I will not tick the resolved box just yet as I have not checked every machine but I think I'm ok.

Thanks for all your help Lastchip

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?