Limited user accounts: difficulty playing games

  TimCDC 18:34 09 Mar 2003
Locked

I've set up my two boys as limited users on Windows XP, with the intention of preventing them making system wide changes while they are unsupervised and playing games. Trouble is, some games seem to only work on my, administrator account. The same games return error messages when they are logged in: things like "can't find the target file", or "can't copy the file to disk". So I have to log them in on my own administrator account, which kind of defeats the object. I've tried giving them temporary administrator status, to install the games; but when I put them back to limited status, the problems return. Does anyone have any suggestions?
Thanks, Tim

  bremner 18:45 09 Mar 2003

This has been a problem since day one with XP and some pre XP games. MS provided a patch for their games but I have not seen any others. It appears to be in the "too difficult box" i'm afraid

  BBez 19:55 09 Mar 2003

try browsing to the game .exe (eg C:\unreal2\unreal2.exe) in the game directory, right click the file, select properties then click on the security tab, then add your user accounts for your sons or "everyone" and check "full control"

  bremner 20:37 09 Mar 2003

Beta

This is the strange thing with this problem.

I have MOHAA a & Jedi Knight running fine with no "tweaking" at all in all users. Yet Red Alert 2 refuses to work for Limited Users.

  TimCDC 21:37 09 Mar 2003

Thanks everyone for these responses - its sorted now! I tried to follow BBez's advice, but didn't find the tabs mentioned. What I did find, and decided to follow up as a result of Bremner's tip, was the compatibility mode option. Knowing that they worked fine in Windows 98, I've simply set up the games to run in compatibility mode for 98 & ME - hey presto, they work now.
This is my first venture on to this site - one happy customer (or more accurately, one parent of two happy little customers!). Thanks, Tim

  TimCDC 13:42 17 May 2003

Have been meaning for ages to come back and record, that, with time, the "solution" I posted earlier doesn't work - or at least most of the time it doesn't. (That's the strange thing - on rare occasions the programmes run ok.). On my further investigation it seems that many older games simply aren't compatible with limited user accounts - full stop. The moral that I've learned is: (a) make sure any games I buy are XP compatible and (b) let my kids use them through my account (but with the deskset utility to help prevent them from doing any damage to my settings!) Tim

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?