Limited or no connectivity with Linksys Router

  kennon 01:56 01 Jul 2007
Locked

First of all, thanks, mgmcc for letting me know to start a new thread and my apologies.

The problem I am having is that I am getting the "Limited or no connectivity" message and Windows is assigning me a "164" IP address instead of a "192"


I did the following which you suggested:
ipconfig/all
ipconfig/release
ipconfig/renew

Igot the following message after ipconfig/renew:
"An error occurred when renewing interface Wireless Network Connection 5: Unable to contact your DHCP server. Request has timed out."

many thanks in advance for any help you could provide

  mgmcc 08:28 01 Jul 2007

The failure to get an IP address from the router is possibly because you haven't "Connected" to it.

Have you run the wireless adapter's software, scanned for "Available Wireless Networks", found and highlighted the one that matches your router's SSID (network name) and selected the option to "Connect" to it? You should be prompted to enter any WEP or WPA encryption key and, once "Connected", the wireless adapter should get its IP address by DHCP from the router and you should have network and internet access.

There is a difference between the Wireless Network Adapter and Router communicating with a good signal and "Connecting" (as in "logging in") to your Wireless network.

  kennon 16:37 01 Jul 2007

Yes, I have run the software (Linksys Wireless Card G) and chose to connect and have been prompted for the WEP key. After this I get the message that I am conneted to the access point, but with no internet (this is with the software's configuration).

If I switch to using Windows XP configuration, it says that it is "Acquiring Network Address" and eventually gives the "Limited or no connectivity" warning after assigning a "164" IP address.

The thing is, it was working fine (connecting to access point and internet) and all of a sudden started giving me this problem (no updates were recently added), and that's why I'm so confused as to what the problem could possibly be.

  mgmcc 19:48 01 Jul 2007

Try deleting the existing wireless 'profile' which could be corrupted, then go through the procedure to "Connect" again when a new profile will be created.

If using Windows' Wireless Zero Configuration, this is done in the Preferred Networks section of the Wireless Networks tab of the Properties of the Wireless Network Connection.

  Strawballs 22:29 01 Jul 2007

Have you tried unplugging the router leaving for about 2 min's then plugging in again.

  Vaith 11:56 02 Jul 2007

Step 1 : Control Panel > Network Connection > right click "Wireless Network connection > Properites.

Step 2 : Uncheck the option (last one), "notify me when there is limited or no connecivity" Uncheck and click on OK.

Step 3: Power cycle the router as Strawballs suggested. you should be online.

Step 4 : If it still doesnt get an 192 ip and has a auto config i.e 169. Repair the network connection.

  kennon 23:18 02 Jul 2007

Thanks for all the help guys, but I'm still not able to connect to the internet. I've tried the last three suggestions and I still get auto-assigned a "169" IP adress(not 164 like I said before).

When I try to repair the connection, it waits for a number of minutes, then ultimately says that the repair failed because it could not renew the IP address.

I know this is frustrating, but any and all suggestions really are appreciated here.

  mgmcc 23:57 02 Jul 2007

Try repairing the TCP/IP stack. Open a Command Prompt window and type:

netsh int ip reset resetlog.txt

...and press Enter

(note the spaces in the command line). The original prompt will reappear, exit the Command Prompt window and reboot the PC.

Also ensure the DHCP Client service is running. Go to "Start > Run" type SERVICES.MSC and click OK. Scroll down to the DHCP Client service, double click the entry to open its Properties sheet then check that the service is "Started" and that its Startup Type is "Automatic".

  lester1 00:13 03 Jul 2007

You could try forcing the router to an IP address
Control Panel>Network Connection>Properties>Networking>Internet protocol>Propertiies>assign TCP/IP.>use the following IP address, then enter the IP you want it to use
The router should find the correct DNS server addy

  mgmcc 09:26 03 Jul 2007

While there are situations where it is beneficial to use a fixed IP address, I would advise against it where there may be a problem actually connecting to the router. It effectively 'hides' the fact that they aren't communicating properly.

Once the wireless network is functioning, a fixed IP address can be useful where there are dropped connections and the DHCP server fails to renew the IP address.

  kennon 03:06 04 Jul 2007

Hey guys,

Just wanted to let you all know that I've finally got the connection working again. Just for information's sake, here's what I did.

1. Uninstalled both router and wireless card software.
2. Did a hard reset (button on back) of both the modem and router.
3. Cleaned up both computers (defrag, delete temp files, etc.)
4. Reinstalled router and wireless card software.
5. Designated Windows to configure connection (seems to be much more reliable than Linksys software).

I'm checking this problem as resolved.
Again, thanks to all of you for the help you provided and I'll definetely keep this site in mind for future problems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone