Limited or No Connectivity!!!

  Alfreddo 03:57 08 Mar 2009


I have a DELL Optiplex GX620 desktop running Windows XP Professional.

A week or so ago, when I tried to connect to the Internet, the LAN symbol in the utilities tray signalled that “this connection has limited or no connectivity”.

I thought it might be the external D-Link router/modem so I connected the LAN cable to my ASUS netbook and everything works perfectly, including the wireless connection. I also tried another router/modem (using the same LAN cable) but it too failed to work with the DELL desktop. Again, the other router/modem had no trouble connecting with the ASUS laptop, both via the LAN cable and wirelessly.

In desperation, I inserted a USB wireless adapter into the DELL but it too failed to connect to the Internet even though it registered as receiving a strong wireless network signal.

Sometimes, the LAN connection to the DELL will become operative after periods ranging from 30 minutes to several hours but, eventually, it will pop up a “limited or no connectivity” message.

The DELL uses a Broadcom network adapter (NetXtreme 57xx) so I used its Broadcomm Advanced Control Suite to do a network test. The result was “Destination IP Could not obtain the Gateway address or the the Network device is set to a static IP address. Please enter the IP address of a remote machine A valid IP address is required”.

As I am writing this, I have been able to connect to the internet for about two hours but I notice the wireless pop-up has just notified me that “this connection has limited or no connectivity”. The LAN connection is still working okay so far but will probably pop-up the same message very soon (ten minutes later it did).

Finally (and this may be a coincidence), when I start up my ASUS netbook, my DELL desktop will then gain access to the internet (???).

Would anyone have any suggestions as to how to fix this problem?

Many thanks.

  mgmcc 13:38 08 Mar 2009

Try repairing the TCP/IP Stack and Winsock:

Open a Command Prompt window ("Start > Run", type CMD and click OK).

To repair the TCP/IP stack, at the prompt, type...

netsh int ip reset resetlog.txt

...and press Enter

(note the spaces in the command line). The original prompt will reappear, exit the Command Prompt window and reboot the PC.

To reset Winsock entries, at the prompt, type...

netsh winsock reset catalog

...and press Enter

Exit the Command Prompt window and reboot the PC. (If running both repairs, reboot only after running the second command.)

  Alfreddo 20:19 13 Mar 2009

Many thanks for your suggestions but, unfortunately, none of them worked.

However, after much trial and error, I was able to get the desktop wireless LAN and LAN to work. But it only works if I turn on the desktop and, at the same time, turn on my netbook next to it. Once the netbook connects wirelessly to the internet, about ten seconds later the DELL desktop will then connect wirelessly (using the inserted D-Link wireless adaptor) and, after an additional five seconds the DELL’s LAN will connect! This doesn’t make sense to me.

So, to sum up, the DELL desktop wireless LAN and LAN will only work after the netbook connects.

Does this give you any further clues at to what the problem might be?

Thanks again.

  mgmcc 20:53 13 Mar 2009

With *BOTH* computers connected to the internet, can you open a Command Prompt window ("Start > Run", type CMD and click OK) then, at the prompt, type...

ipconfig /all

...and press Enter. This will show details of all network adapters installed in the PC. Right click in the Command Prompt window, "Select All" and press Enter to copy the details to the clipboard. Paste the details into a forum reply here.

Post the "ipconfig /all" details for each computer, which might just give a clue as to the problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017