Light on power switch just flashes

  Strawballs 19:21 29 Mar 2007

On my brother-in-laws PC when the power swith is pressed all that happens is the light on the switch flashes and the CPU fan starts and speeds up and slows down, it does not even get to post screen.

I have tried it on a different monitor, tried a different memory stick, unplugged everything except the memory but still no post screen and I have tried a different PSU.

  bennyhillslovechild 19:28 29 Mar 2007

Hmmm - Sounds like your motherboard may have gone for a burton. Try removing and reseating the RAM, you could try removing and reseating the CPU, but if you do that remember you will need to reapply some thermal paste or a pad.

It may be worth first however, resetting the CMOS using the jumper - it probably won't do anything, but I have managed to bring a couple of computers in the same state back to life by doing this.

  Strawballs 19:36 29 Mar 2007

I knew I would forget something that I have tried, I did the CMOS jumper reset and the memory as I said I tried a different stick out of my daughters PC which I know is working.

Will need to get some paste to try reseat of CPU but I too am starting to think dead MoBo, shame as the PC is only about 2 years old Packard Bell.

  Fruit Bat /\0/\ 19:37 29 Mar 2007

My first guess would be PSU failure.

Try disconnecting and reconnecting all PSU to motherboard connections.

Then try another PSU (cheaper than a motherboard)

Also worth a remove / refit of memory modules and graphics card.

  Strawballs 19:43 29 Mar 2007

I have tried a different PSU because that was my first thought.

  bennyhillslovechild 19:48 29 Mar 2007

I just remembered one other thing to check, Strawballs - make sure the motherboard isn't shorting to the case....My PC suddenly developed the same symptoms just before after christmas, and I was pulling my hair out. Bought a new PC in the end, and decided to take apart my old one for spares. Completely took it apart, and when I lifted out the motherboard, a loose screw feel out. Looks like one of the screws holding in a optical drive had fallen out and made it's way behind the motherboard as I moved computer around. I put everything back in as it was(minus loose screw)and computer started up fine. I was a bit chagrined at first, having spent that money on a new machine, but these things happen, and now I have my old machine folding away happily 24/7.

  Strawballs 19:55 29 Mar 2007

Thanks for that bennyhillslovechild will check that out.

  Strawballs 00:10 31 Mar 2007

I will tick this one as resolved because I have been onto a Packard bell forum (just to have a nose) and this sems to be a common problem with this model and the solution was always a new motherboard, thanks anyway to all that helped.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017