LEXMARK P4350 problem

  claluc 17:39 18 Nov 2006

Am having problems with this device. When installing, the usual wizard "Found new Hardware" pops up for all components but at the end I get this message: There was a problem during setup, your new hardware might not function properly.
When installing the drivers the download disapperas half way through the process.
The printer and associated functions all show up in Start Programs (and printer works perfectly well) but there is no trace of the Lexmark Imaging Centre with Scanner and Copier sections.
In System-Hardware-Device Manager under "Imaging devices there is a "Scan" device with the yellow warning sign, this shows no location or drivers installed (Error28) and won't allow uninstall as the following message pops up: "Uninstall impossible, this device might be required for system bootup".
I am sure this is what is causing the problem with installation of the Lexmark but how can I get around it?
By the way, the same all-in one has been installed on another PC with no problems whatsoevere, so there is no fault with the device itself.

PC is a PANRIX Magnum 3500 running Win XP Home and is only 6 months old. (No need for comments about Panrix, just read my other post!...don't rub it in!)
I have purchased a system tuning software - PcOnPoint- which has corrected all errors in registry etc but this has made no diffrence.
Also been in touch with Lexmark Technical support but all solutions they suggested don't work.
Any idea?

  skidzy 18:24 18 Nov 2006

Is it listed as a startup program ?

Have you tried to uninstall from Add and Remove Programs ? if successful then run Ccleaner click here and reboot.

Then reinstall the software.

If no luck,try:

Start / Run / type MSCONFIG / remove everything under startup associated with Lexmark and reboot.
Now do you still have the Device Manager conflict ?

  claluc 22:05 19 Nov 2006

Done all of that and managed to remove the conflict device.
When reinstalling it all happened again. same scenario.
I have also changed the device for a new one(PC World kindly accepted to exchange it), exactly same problem so we now know 1 thing for sure: The printer itself is not at fault.
I have downloaded the latest driver from Lexmark .com and after a lot of tweaking I have managed to make the Lexmark All in One and Imaging Centers appear in the start menu, all functions work except for the scanner, have tried to force drivers through but the result is always the same, it won't install them reporting the same message: Problem occurred during instalation "invalid data".
I performed system cleanup and various checks including sfc /scannow, Event Log shows dozens of application errors and also errors due to a bad sector on disk.
Have tried to run a repair through C/error checking but this causes freeze during phase4 with subsequent reboot and "system recovered from a serious error" report.
I have sent the report to Microsoft and the return relates this to a recent driver installation with no further explaination.
Pretty obvious I have a problem in the system but would like (if at all possible)to identify what it is and avoid a complete reformat and reload of XP as I have several software installations for which I no longer have disks to reload.
Oh another thing,....I have tried to copy files from C/Documents and settings in view a possible reformat and this was impossible, they would not transfer to CDR due to system errors.
Not been in luck with PCs lately!!!

  skidzy 23:04 19 Nov 2006

Just a quick thought,do you have any other printer software installed ? if so uninstall this.

You obviously have a conflict with some program,but its going to be a matter of elimination im afraid.

Does Device Manager show any other yellow exclaimation marks ?

Couple of apps to run and reboot click here click here

These may give your registry the clean they need.Make sure you uninstall the Lexmark software before running these.

  claluc 23:16 19 Nov 2006

No no other yellow marks.
I used to have a Lexmark Z54 printer but all related software has been removed.
During the many attempts I made sure anything with references to Lexmark had been removed, this includes registry.
I will give your links a try tomorrow but I have already run both CCcleaner and PConPoint which seem to be the same sort of software, still same result.
Am actually wondering if all this cleaning up hasn't upset my system even more as tonight even IE seems to have a mind of its own.....
What do you think about the bad disk sector problem? any possible relation? Maybe some missing installation instructions?

  skidzy 23:32 19 Nov 2006

Can you post the current driver you are using for the Lexmark,you may find it better to go back to an older version.

Have you defragged the HDD recently , if so the warnings you are getting my well be resulting in a faulty HDD.

Cleaning your system should give it a better stability but sometimes the registry could become corrupted.

Can you use system restore to a time before this new Lexmark was installed.

  claluc 09:13 21 Nov 2006

Here is the driver installed as copied from the Lexmark site:

File Name: cjb4300EN.exe


Released On: 11-MAY-05

File Size: 38806 KB

Products: Lexmark P4330, Lexmark P4350

Languages: English

Operating Systems: Windows 2000, Windows Server 2003, Windows XP

Application: n/a

Owner Name: Lexmark

Data Stream: Lexmark Host Based Solution, Lexmark Scan and Copy Control

Security: Public

In response to your second question yes I have defragged recently but this had not reported problems. Mind you I didn't really look thoroughly into it, I will redo and check.

I have indeed done a couple of cleaning sweeps as said before, I thought these programs were to clean up the registry, not corrupt it?
The other problem is that at the end of a scan, be it CC cleaner or any other program, these throw up lists of items to remove with the usual questio: "Are you sure you want to delete these files"? Well the answer is: How is one supposed to know???
In fact since then I have lost shortcuts on my desktop and links in Start/Programs, this to add to the printer installation problem.

As to restore the PC to a previous date, since running sfc /scannow with the Win XP disk in the CD Drive, all I have been left with is November, all other months and restore points have vanished, so the answer is I can't restore to earlier dates anymore.

  digmymusic 00:56 12 Apr 2007


I had exactly the same problem as you and have just solved it. One of the instructions you have is to cancel all hardware found pop ups. I have XP and was sometimes getting these when trying to install and was cancelling them as requested, however I was also getting speech bubbles from the tool bar at the bottom of my screen re new hardware. I think this is what is messing you up. All you need to do is ensure that you unplug the usb cable from the printer(i.e. don't follow the lexmark instructions)completely uninstall and reboot, then run install. You should notice a difference during the software installation and then when it gets to detect printer it will ask you to plug in the USB cable and Bob's your uncle. Once you plug it in everything kicks off properly.

My theory is that there is probably a configuration setting somewhere in XP to automatically locate and install new hardware and this is causing the install problem.

Happy Scanning!!

  digmymusic 01:03 12 Apr 2007

Alright Boss!!

I've just posted the solution to your Lexmark P4350 problem. Perhaps you have already sorted it but just in case.

All the best.


  worldswizkid 01:19 15 Apr 2007

yh your missing drivers m8 follow claluc instructions and your problem will be fixed

  worldswizkid 01:25 15 Apr 2007

yh your missing drivers m8 follow claluc instructions and your problem will be fixed

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017