Last hope - unable to repair windows

  Mooma 08:55 21 Dec 2005
Locked

A few weeks back NIS said there had been an attempt to change registry values so I chose the 'block' option. Ever since then I have been unable to run any programs as the computer doesn't recognise them although they are still there. I have tried a registry repairer and system restore to no avail. I have also tried a windows repair (XP) but it stops when it gets to the point where it doesn't recognise the file 'rundll32.exe'. It also won't run or repair NIS. Does this mean I have to wipe everyhting clean and start again??

  medicine hat 09:23 21 Dec 2005

Hopefully not. When attempting your repair did you run the System File Checker?

Go to Start->Run and type sfc /scannow

You could also try getting a new rundll32.exe:

Put the Windows XP CD ROM disk in the CD ROM drive then go to Start->Run and type
expand D:\i386\rundll32.ex_ c:\windows\rundll32.exe
(assuming D is your CD ROM Drive)

Hope this helps

  Graham ® 09:43 21 Dec 2005

You could have been infected with a virus or other malware. The fact that Norton alerted you would indicate this. Some viruses will prevent anti-virus programs from running, and make repairs difficult too.

  Mooma 10:09 21 Dec 2005

Thanks for replies. Unfortunately my machine is stuck in setup waiting for the file. It can see it but doesn't recognise the program which created it. I didn't run filechecker - I didn't know about it. My first thought was a virus although I thought I had stopped it by 'blocking' the changes. I originally also tried using the NIS emergency disc which didn't indicate any virus when it scanned though. The only way I can access anything is via DOS and I don't know that much about it....I've spent weeks on this now as it's all trial and error for me!

  Graham ® 14:27 21 Dec 2005

Shut down the PC by holding in the power button. Then re-boot and see if it will start in Safe Mode - usually done by tapping F8 as it starts to boot.

  Mooma 15:17 21 Dec 2005

Yes done that but it wants to go back to set up and says it can't operate setup in safe mode. Can only get the command prompt to do anything....

  Fruit Bat /\0/\ 15:47 21 Dec 2005

First give the XP CD a good clean or borrow another one and retry "set up"

If no go then

1. Boot the computer using the XP CD. You may need to change the boot order in the system BIOS so the CD boots before the hard drive. Check your system documentation for steps to access the BIOS and change the boot order.

2. When you see the "Welcome To Setup" screen, you will see This portion of the Setup program prepares Microsoft Windows XP to run on your computer:

To setup Windows XP now, press ENTER.

To repair a Windows XP installation using Recovery Console, press R.

To quit Setup without installing Windows XP, press F3.

3. Press Enter to start the Windows Setup.

To setup Windows XP now and Repair Install , press ENTER.

choose "To repair a Windows XP installation using the Recovery Console, press R".


4.Select the instalation to boot to usually #1

5. At insert Amin pasword typethe password or just press enter if no password set.

6. Now in Recover Consul you will probably have the C:\windows propmpt.

7. Type expand D:\i386\rundll32.ex_ c:\windows\rundll32.exe (where D is the drive letter of your CD drive)

8. Remove CD abd type exit to reboot the PC

  Mooma 11:10 22 Dec 2005

Sorry no go! I tried the recovery consul before but it won't get past the admin password bit, even though I have never set up a password. Even pressing enter doesn't work. I managed to get into the repair mode via another option and that's where it's stuck. I don't think the cd is faulty. None of my exe files will open in windows, which is why I think I am having a problem with the rundll32.exe. Windows won't recognise any of them - it keeps asking which program created them.

  Mooma 07:19 24 Dec 2005

Hello again....
Just wondered if anyone had any more ideas as I'm still stuck in limbo!
Hope everyone has a very good Christmas x

  VoG II 07:23 24 Dec 2005

Try this click here

  Mooma 07:39 24 Dec 2005

Thanks. Have to go out now but will try as soon as I get back.
Merry Christmas!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?