Laptop won't even reach bios screen.....

  Lightchop 09:18 28 Feb 2007

Hi - wonder if anyone has any pointers for this?

Fujitsu lifebook E6530 laptop. An old unit I use for messing around on!

Issue: On switching on, fan briefly runs (which is normal), HD spools up - then nothing. No splash or bios screen (in fact no display whatsoever). No further HD activity, therefore ruling out purely a display problem. The machine shut down perfectly the previuos evening and has not been showing any signs of pending malfunction.

Remedies tried:

A different HD (although this was never really suspect)

RAM seating checked.

Battery and AC power removed overnight

System reset with master reset pin.

Any ideas before I bin it? I was thinking possibly CMOS battery or a mobo issue (can't locate battery to check at this stage dispite some dismantling).

Thanks in advance.

  crosstrainer 09:22 28 Feb 2007

Might be a BIOS issue, but would still expect you to get display, even if the battery were dead. Can you connect it to another monitor?

  Fruit Bat /\0/\ 12:30 28 Feb 2007

HAve you tried boot from mains adator with the battery removed?

  Lightchop 12:38 28 Feb 2007

Thanks for the replies - yes, have tried booting just on mains with no battery. I can try anither monitor - I've done some more googling and that's definitely something I need to try, also trying different RAM anda different mains adaptor, both of which I have access to.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?