laptop wifi to desk w/ cable modem & USB wifi

  aphotic_noise 00:27 02 Dec 2007
Locked

I used to have this setup and working properly. Had to reformat HD and can't get it running now.

I have a desktop connected to the net via an Ariss cable modem through a LAN cable. I also have a Belkin USB wireless device on that desktop. I'm trying to connect my laptop wirelessly to my desktop to use the internet. I've installed the Belkin 3rd party software which sucks, so I run in Windows Zero Config mode. The laptop also uses Windows for wireless config. All firewalls are off.

The SSID's are the same, the keys are right. (I have tried using Open and no key as well.) I don't get limited connectivity messages, however I cannot access any webpages. I tried using the IP address to reach websites thinking I could bypass DNS, but that didn't work either.

I keep getting Automatic private IPs assigned to the laptop. I've tried reinstalling the drivers and 3rd party software for the desktop wireless USB as well.
Here's the desktop:

Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address : 68.109.12.27
Subnet Mask : 255.255.255.0
Default Gateway : 68.109.12.1
DHCP Server : 172.19.17.22
DNS Servers . . . . . . . . . . . : 68.105.28.12
68.105.29.12
68.105.28.11
Lease Obtained : Saturday, December 01, 2007 6:05:17 PM
Lease Expires : Sunday, December 02, 2007 6:05:17 PM

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description : Belkin 54g Wireless USB Network Adapter
Physical Address. . . . : 00-17-3F-14-7B-1A
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address: 169.254.176.164
Subnet Mask : 255.255.0.0
Default Gateway:

Here's the laptop:
Host Name . . .. . : xxx
Primary Dns Suffix . . . :
Node Type . . . : Mixed
IP Routing Enabled. : No
WINS Proxy Enabled : No

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description : Atheros AR5005G Wireless Network Adapter
Physical Address : 00-11-F5-89-67-D4
Dhcp Enabled. . : Yes
Autoconfiguration Enabled : Yes
Autoconfiguration IP Address : 169.254.66.80
Subnet Mask : 255.255.0.0
Default Gateway :

  aphotic_noise 00:41 02 Dec 2007

I've also enabled Internet Connection Sharing and run the Network Setup Wizard on both computers.

  MAJ 01:05 02 Dec 2007

Have you tried ipconfig /release and ipconfig /renew from a command prompt?

  aphotic_noise 01:31 02 Dec 2007

Yes, I have on both computers and it hasn't worked yet. Connected to the network but no net access on the laptop. Also tried /flushdns and spent hours so far playing with static IPs in the private range for the desktop wireless and laptop wireless. For all the trouble this is worth I'm wondering if buying a wireless router would be easier.

  MAJ 01:48 02 Dec 2007

Have you set the wireless adapter to adhoc mode rather than infrastructure mode?

  MAJ 02:03 02 Dec 2007

Oh and yes, buying a wireless router would be easier, setting up an adhoc wireless network with ICS can be an absolute pain at times.

Darn I hate typing on laptops, time for bed, I think.

  aphotic_noise 02:30 02 Dec 2007

Ok, switched the desktop from infrastructure to adhoc. Also assigned a static IP address to the desktop USB device and for the first time all day the laptop wireless is being assigned an IP by DHCP. Still no net on it though. Would I need to set the default gateway for the wireless on the desktop? (DNS too?)

  MAJ 09:36 02 Dec 2007

Here's a step by step tutorial on how to set things up, aphotic_noise. click here

  aphotic_noise 16:21 02 Dec 2007

Yeah, I looked at that among many other networking related posts before posting my problem. Didn't fix it. I think it had something to do with the Belkin USB software because it was supposed to be in Windows Zero Config, but it would show a tooltip that it was connected to a different network than the windows wireless network icon. I bought a router so problem's resolved now. It was MUCH easier to setup.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?