Laptop usb ports and device manager not working!!!

  julius44 07:42 20 Jun 2010
Locked

Hello i was at my friends place yesterday, trying to sort out her laptop for her to not avail. She has a dell inspirion 9400 laptop running a 32-bit version of windows vista. Her 6 usb ports no longer work, and when i tired to access the device manager, i get the following error message:

mmc could not create snap-in. The snap-in might not have been installed correctly. Name: Device Manager CLSID:{74246BFC-11D0-ABEF-0020AF6B0B7A.

She's not great with computers, and I know for a fact the laptop has not been opened at all so i know that no hardware has been changed in it. I just need to get a solution to this problem. I've googled this error message, and the solutions seem to be complicated for which i dont really understand. I really need a straightforward solution please, something very easy and STRAIGHT FORWARD to understand and resolve urgently please!!!!!

  birdface 08:30 20 Jun 2010

Maybe a system restore to a time when it was working.
Give Malwarebytes a try in case there are any nasties on board.
click here

  birdface 08:33 20 Jun 2010

117 on right hand side.

click here

  birdface 08:34 20 Jun 2010

Oops 107 I should have said.

  Atlantic Man 08:35 20 Jun 2010

Yeah mallwarebytes- cause it seems like spyware to me, they usually hi-jack system components-

If no spyware is found and system restore does not work, try repairing windows from the original disk- just insert the disk, boot from it- then select the setting in the left-bottom corner that says "repair my windows"

Cheers

  birdface 08:46 20 Jun 2010

Another one to try maybe.

click here

  julius44 09:58 20 Jun 2010

Hi buteman, one of the links u sent me is for windows xp registry tweaks, but my friend has a 32-bit vista machine, if u can kindly send me the link for vista that'd be much appreciated.

  Fruit Bat /\0/\ 13:50 20 Jun 2010
  julius44 18:24 20 Jun 2010

Thanks loads fruitbat for the link, i just do not know how to go about doing this properly please....and I man the start and run menu, and what I need to type in the command in to resolve the problem. Many thanks for your help

  Fruit Bat /\0/\ 20:30 20 Jun 2010

Click Start
In the Search box type

cd %SystemRoot%\system32

press OK
type

regsvr32 mmcndmgr.dll

press OK
type

regsvr32 inetmgr.dll

press OK

Uninstall and Re-install IIS
To uninstall,
Click Start Select Control Panel select Add/Remove Windows Components

Check 'Application Server', click 'Details' | Uncheck 'Internet Information Services' | Click 'OK'

To install, Start | Control Panel | Add/Remove Windows Components | Check 'Application Server', click 'Details' | check 'Internet Information Services' | Click 'OK'

  julius44 21:32 20 Jun 2010

thanks fruitbat, i'll try this for her when i see her again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?