Laptop suddenly won't connect to network

  Logov 12:19 25 Dec 2009
Locked

Hi

I've been using my sony vaio (with vista)on a shared network at home for about a year without issue. All of a sudden it won't access the network at all. It sees the network which is usually at full strength, but when I click connect, and after a brief pause I get the message "cannot connect to network". I can connect to the network wirelessly from another pc but not with the laptop. Obviously something has changed but I'm at a loss to understand what or why.

Any ideas?

  Graphicool1 13:08 25 Dec 2009

In case you've inadvertently deleted something by mistake do a 'System Restore' back to before this occurred.

  Woolwell 17:33 25 Dec 2009

Try turning firewall off briefly.

  User-1229748 17:40 25 Dec 2009

if you right click on your network icon bottom right of screen and click troubleshoot or repair what does the result say?

  woodchip 17:49 25 Dec 2009

If you are using Wireless, as him if he as shanged the Router Encryption key

  Logov 00:40 26 Dec 2009

I tried connecting via ethernet cable and that worked fine - so all router/network settings seem to be ok. I then retried connecting wirelessly but again no joy.

Have done System Restore but didn't solve the problem.

According to the "Windows Network Diagnostics": "Wireless association failed due to an unknown reason"

Perhaps this is a hardware problem as system was restored to a point when I know wireless access was possible and I can access network via cable but not without. If so what can I do?

  User-1229748 12:40 26 Dec 2009

back up registry if you try this fix click here

  User-1229748 12:42 26 Dec 2009

sorry scroll down to the fix

  woodchip 14:37 26 Dec 2009

If I was you, go into router setup page and create a new encription for wireless, then put that into your Wireless Laptop Network Settings. Before you leave setup page make note of the SSID you may need that also

  Halmer 15:01 26 Dec 2009

it by uninstalling then reinstalling the network adaptor thro device manager.

  Logov 08:18 27 Dec 2009

I tried the registry fix - no joy.

Unistalled and reinstalled network adapter - no joy.

I'm now thinking there may be an issue with the router's wireless settings as I tried wireless access with another laptop and that too couldn't connect whilst being able to do so via ethernet cable.
Router is a Linksys WAG200G. Have had this for around 2 years and has been flawless up until now.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?