laptop not powering on and not charging

  slam888 17:14 05 May 2009

got a toshiba satellite a100-583. i've changed the dc socket and got a new ac adapter. and it still not working. i looked at the motherboard and see no burn marks.
what else could be the problem?

  Pineman100 17:48 05 May 2009

Have you checked the power cord from the new AC adaptor to ensure that it is actually delivering current to the DC socket?

Have you checked inside the DC socket to ensure that none of its connections are broken, and that it is receiving power from the plug?

If you're able to charge your battery elsewhere, it might be worth trying to start up on battery power, and see if that works.

  Fruit Bat /\0/\ 18:51 05 May 2009

Tried with battery removed?

  slam888 21:52 05 May 2009

tried it with the battary off.

AC adaptor is a unversil one. and the DC socket it brand new with plug in wire.

i cant charge my battary anywhere elses.

how would i check if its deliverying current? current

  Technotiger 22:02 05 May 2009

The problem could be the AC adapter - is it really suitable to run a laptop?

Universal ... could be the key word.

  slam888 09:24 06 May 2009

it is a universal laptop adapter. i have tired the adapter with different laptops and it works.

its kinda bugging me

  woodchip 09:27 06 May 2009

May have blown the MOBO but you could check things around where you connected the new socket for dry or bad joints in solder or it could be a component

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?