Laptop not behaving!!!

  TheGmyster 20:47 05 Aug 2010
Locked

Hi all.

My laptop is behaving very strangely recently.A few weeks ago it became infected with a virus which rendered all my progs unworkable.I finally thought i had sorted the problem by doing a system restore then ran my anti-malware wich did not pick up anything dangerous at all.Since then the laptop has been behaving oddly,by which i mean when i click on a Google Search result it doesnt always take me to the intended site,but rather directs me to other smaller search engines/sites 2 or 3 times before i get to the site i want.

Also my Avast home anti-virus keeps alerting me even when im not connected to the internet!! but again my anti-malware software picks up nothing.

I am able to use my laptop but i just know that it's not behaving as i am used to...Can anyone help? Thanks.

  tullie 20:59 05 Aug 2010

Have you run a full scan with Avast?

  TheGmyster 23:42 05 Aug 2010

Hi Tullie no i havent run full scan with Avast, just with my AntiMalwarebytes software. will try it tho. also i forgot to mention my Windows updates are not working. I get msgs saying things like 'Windows support has stopped working'or things along those lines.

  Les28 16:44 06 Aug 2010

Just a couple of ideas. As well as a full scan with Avast as suggested, have you tried a boot time scan with Avast?

click here

Also your anti malware bytes software is it MBAM, Malwarebytes Anti- Malware?

Maybe the malware has infected the system restore points, possibly your hosts file is redirecting to other sites, but maybe just deleting your temporary internet files may help.

What exactly does Avast alert you to, maybe just a suspicious temporary internet file?

  woodchip 16:49 06 Aug 2010

Sounds to me that when you get an alert you just turn it off without doing anything about it. It no good waiting till the house burns down, before you decide you cannot put the fire out and you need a fire engine

  TheGmyster 17:52 06 Aug 2010

Hi thanks for all your suggestions. My anti-malware is Mbam. The Avast sometimes alerts me to 'suspicious URL blocked' and sometimes 'Trojan horse blocked' I did a quick scan and it pulled up 1 severe infection wich I moved to the virus chest. I will tryvusing my laptop again and see what happens. Also I will try a boot-time scan. Thanks all again.

  woodchip 18:52 06 Aug 2010

When you ran Restore, it will have put Virus back as they get into the Restore point.. One of the Main things in Restore is the Registry this is where Virus will have made changes before the restore point was created most likely

  Les28 19:29 06 Aug 2010

If you continue to have problems maybe a specialist malware removal site like

click here

Have a look at "Preparation guide for use before using malware removal tools and requesting help" in Topic Title.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?