laptop keyboard gone strange

  PIE THROWER 19:52 04 Jun 2008
Locked

I tried plugging in a PC keyboard to my laptop (which worked fine). Once though I unplugged it to return to using the laptop's keyboard a problem started.

When pressing a key where a number is a 2nd function (eg K and 2) the 2 has become the default (the K won't type.) Otherwise the rest of the keyboard works normally.

Thanks for any tips.

  brundle 19:52 04 Jun 2008

Press numlock, or check Numlock setting in BIOS

  PIE THROWER 22:27 04 Jun 2008

Tried the number lock but now noticed the problem is with other keys eg # and ~key can only display ~.

  rossgolf 22:30 04 Jun 2008

try the keyboard language layout in the keyboard settings in control panel

  PIE THROWER 23:11 04 Jun 2008

the keyboard language seems to be ok - all the settings in "keyboard" and regional settings report that I am set up for the UK

  ronalddonald 13:13 05 Jun 2008

U could go to system restore. Or back up your files on another drive or doggle and do a repair or reinstall the OS.

  woodchip 13:18 05 Jun 2008

Check if Device Manager is showing two keyboards, if it is remove the desktop one

  PIE THROWER 19:24 05 Jun 2008

Only one keyboard shows in device manager. I have wanted to just reinstall XP but apparently I can't be trusted to do that right after messing up the keyboard. Is there any other options ?

  woodchip 22:13 05 Jun 2008

Reload Drivers

  woodchip 22:14 05 Jun 2008

Its using the wrong driver

  PIE THROWER 08:12 07 Jun 2008

I tried uninstalling the keyboard and rebooting to reinstall it - does that reload the driver? Whatever the case uninstalling hasn't changed anything. How is it I can reload the driver ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires