Laptop freezes when playing DVD using ANY player

  YinHoNg 19:02 10 Jan 2006

Hiya. When i try to play a dvd using my laptop, the whole computer freezes. I've tried it with power dvd, windows media player 10, and realplayer. All with the same result.

Can anybody help?

  YinHoNg 19:04 10 Jan 2006

Just to let you know, i've recently formatted my computer so there aren't any dodgy programs on it.

  GuZ><0r 19:11 10 Jan 2006

Have you done any any anti-virus/spyware scans since the re-format?

  zarobian 20:44 10 Jan 2006

Have you installed the latest driver for your graphics card? If not try updating your graphics driver.


  zarobian 20:46 10 Jan 2006

Hope you have sufficient physical memory installed. 256/512 MB of RAMS will be sufficient.

  YinHoNg 23:32 10 Jan 2006

I'm using omega drivers because the official ones from the ati site came up with an inf error when i was trying to install it...

i've got 256MB of ram installed with 64M going to the VGA.

  007al 23:36 10 Jan 2006

Do you have a driver disc that came with the laptop?

  Yoda2002 10:22 11 Jan 2006

is the dvd region right ?? you may have change the pc reigon to default or the dvd your trying to play try going into real (the player i know the most) and change it BE WARNED YOU CAN ONLY CHANGE IT LIMITED TIMES!!!

  YinHoNg 11:34 11 Jan 2006

I tried the driver disc that came with the laptop and it still didn't work! I've uninstalled and installed it again(through device manager); disabled enabled.... its just one of these hardware that has problems installing drivers!

I'll try that dvd region thing......

Anyone have any idea how much a new dvd drive for a laptop costs?

  zarobian 23:33 23 Jan 2006

As I wrote before it is more likely graphics software problem. Needs to check on the Manufacturers site for an update if available.

Also please make sure that the DVD is running in DMA Mode. To check this, hold down the Start Key (Windows) and hit Break key. This will launch System Properties. Click on Hardware tab and select Device Manager.

Now go down the list of devices and click on (+) sign against IDE ATA/ATAPI Controllers to expand. Presumably your DVD/CDROM drive will be on the Secondary IDE Controller. Double click on this to open Secondary IDE Channel Properties page. Now click on the Advance Settings tab. The transfer mode will be shown as “DMA if available” and the current transfer mode as “Ultra DMA mode 2”. If it is shown as PIO mode then click on the drop down arrow and select “DMA if available”.

This should have been selected by default but you never know. Good luck.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

50 best online Adobe XD tutorials

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?