Labtec Optical Mouse Pro

  Wehttam 16:04 10 Jun 2008

I have this mouse, and I put it away in lieu of a better mouse. Said better mouse has recently broken. Now when I tried to put the old mouse back to use, the computer doesn't recognize it and the drivers I've downloaded from their site are not working. The site says that the mouse does not support Vista (I'm using basic), but it worked fine in the past. Any solutions?

  brundle 16:29 10 Jun 2008

Remove any drivers for both mouses..mice....Reboot. The site doesn't list support or drivers for Vista, but it ought to work without them, you might miss support for extra buttons but as I say, it should work regardless.

  Wehttam 18:21 10 Jun 2008

That didn't work :(

When windows looks for the drivers i get an error saying the INF is out of date or something.

  brundle 20:20 10 Jun 2008

And it worked before on that machine?

  woodchip 21:47 10 Jun 2008

All you need do is in Device Manager, Uninstall all mice. Restart computer using keyboard

  woodchip 21:48 10 Jun 2008

Have the mouse connected that you want to use. do not load any drivers

  Wehttam 23:06 10 Jun 2008

Yes, it has worked with this machine b4, and its a laptop, so it has the pad, will that affect the removal of all mice?

  Wehttam 23:08 10 Jun 2008

Oh, forgot to mention, since I had used this mouse last i had re-installed my operating system etc. A total restart. Idk if that changes anything. Normally I'm tech savvy, but I'm dumbfounded on this problem :P

  brundle 23:17 10 Jun 2008

Shouldn't make a difference, either of the things you mention. woodchip's suggestion ought to work. The pad uses its own software.

  Wehttam 23:46 10 Jun 2008

It mustn't be the mouse that's the problem. I keep getting the same error for all of 3 mice i put in. The only one that seems to work now is the one i'd been using for the past day (which is a terribly small laptop mouse) and even that one gave me the error before it spontaneously started working.

Here is a link to the error:
click here

I get this error when I try to install any mouse. Not just the one mouse that i've been trying to install...

  brundle 23:48 10 Jun 2008

One of the .inf files in Windows/Inf may have been replaced with an older version. Vista tries much harder to stop you getting into the folder than XP did. Try a system file check; click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?