KT 400 BIOS and Number Lock

  Chris the Ancient 18:58 27 Apr 2003
Locked

I have just got a new 'puter with a K7 Triton 400 motherboard fitted.

Nowhere in the BIOS can I see a reference to booting up with the number keys ON. So, it boots up with the number keys off.

Anyone found a way round this?

Can it be 'fudged' in Win XP using the scan keys method (in words of one syllable or less that I can follow)?

TIA

Chris

  spikeychris 19:04 27 Apr 2003

Click Start/Run/Regedit

HKEY CURRENT USER\Control Panel\Keyboard\InitialKeyboardIndicators

0 = numberlock off
2 = numberlock on

If you want the numlock on at the welcome screen you also need to change:

HKEY USERS\.DEFAULT\Control Panel\Keyboard\InitialKeyboardIndicators
same number values as above.

Or...

Create a vbs file and put it in the start folder:

set WshShell = CreateObject("WScript.Shell")
WshShell.SendKeys "{NUMLOCK}"

Chris

  Chris the Ancient 19:13 27 Apr 2003

One day I'll get the hang of being able to post a reply and a tick!

Megathnx mate. I knew someone would know and you beat 'em all.

Shall have to wait until I've done this week's paperwork and got ready for next week before I can try it out. Then I shall crawl back beneath the desk, swap over all the leads and do some more system building.

(ps. When aren't you in the Helproom?)

Chris

  spikeychris 19:31 27 Apr 2003

am I glad your not doing it now...PLEASE DO NOT RUN THE SCRIPT!!!! it just killed my keyboard, I had to run a reverse script..

Just change the registry and it will work fine.

Re: when am I not in the helproom......when I'm asleep... ;o)

Chris

  Chris the Ancient 19:38 27 Apr 2003

I think I shall ignore that script then!

Chris

(all the best people are called Chris LOL)

  BrianW 20:21 27 Apr 2003

Chris, there is a simple way to do this and other "Hidden" BIOS changes with this Triton 400. When you get into your BIOS screen, press control + F! keys and you get to a lower level which has all the more interesting BIOS changes, including Numlock. I think they try to protect the "average" punter from themselves?

  BrianW 20:23 27 Apr 2003

note CTRL + F1 (not F!)

  Chris the Ancient 20:26 27 Apr 2003

Thanks for that.

I *thought* I had tried that (but then, I tried so much) and thought not a lot happened. But, I have to admit to have been getting a bit tired at that point so may not have done it right. I'll give it another go.

Chris

  Chris the Ancient 20:42 27 Apr 2003

Just had a go at the Ctrl+F1 thingy. Didn't do anything! Maybe because I've got an M$ natural multimedia keyboard with funny function keys. (But that was another, resolved, story!)

The caption at the bottom of the screen flashed a couple of times and that was it.

So, tomorrow evening - I think, I shall try it with a standard keyboard and also try try do spikeychris's thingy to the registry and play then. Can't do it tonight now because Der Boss is on her m/c and this one is the server for the network. If she can't do her prints.........

Thanks a lot guys.

Chris

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?