Kodak EasyShare - mprapi.dll not found

  Zak 08:03 01 Aug 2004

Just treated myself to a Kodak EasyShare CX7430.

I am running Win98se and unable to run the Kodak EasyShare program. Error message:


Installation went smoothly and I have installed in safe mode as per Kodak's instructions.

I have uninstalled twice as also used the supplied disk with version 3.3 and also downloaded the later version 3.4.

Tried Kodak site with no success. I have also emailed Kodak support and waiting for reply.

Anyone able to help please?

  gudgulf 09:31 01 Aug 2004

click here You can download the missing file from here.

  Zak 13:40 01 Aug 2004

Thanks gudgalf, I've tried that and it does solve that error message.........however it results in another error activeds.dll not found. When I added this one it then through up adsldpc.dll not found. Finally added that one and reulted in even more items missing.

All these files appear to be Windows NT/XP June 2003 date stamp. From google search I found very little apart from confirmation mprapi.dll is not a Win98se dynamic library link file.

If I don't get this resolved I'll probably take the camera back and get a refund. Thankfully it is still in its seale polythene bag.

Anybody using Kodak EasyShare software successsfully with Win98se?

  Salinger 13:46 01 Aug 2004

Usually the easiest way is to use a Card Reader. Don't know of many professionals who would be bothered hooking up their camera.

  gudgulf 14:02 01 Aug 2004

I have Easyshare on my pc at home running (on xp) without problem...I'm not sure of any issues with Win98se.I am not at home right now so can't check the instalation cd to see if there are specific drivers for 98.The kodak site was not very useful.I will look into this further when I get back home(late tonight) and see if I can find an answer for you.

  Zak 14:15 01 Aug 2004

Your help greatly appreciated, thanks again gudgulf and I await further information.

Salinger, I have considered this as a possibility.

However it would be nice to also be able to use the onboard 16mb memory.

  gudgulf 21:54 01 Aug 2004

Hi Zak,I have had another look at this and I'm not sure what the problem is.

Do you use Easyshare already? If you do and have upgraded to the software that came with the camera then this may help click here=

If you have not used Easyshare before then try this anyway and reinstall the software afterwards.Kodak have some tips for problems when installing click here

Hope this is some help.

  Zak 16:58 02 Aug 2004

Thanks gudgulffor your further suggestions.

This was a clean instal as I have never had this software before.

I have followed Kodaks recommended instal procedures.

I have now done a custom instal, installing only the Camera Connection Software. This loaded successfully and so far no error messages. Camera communicates with PC aand vice-versa. I am able to access both internal and SD Card memory with My Computer or Explorer.

Still waiting for reply from Kodak. It may well be that I will use other Photo Editing/printing and Storage software. Previous month's PCA Cover Disk has Ulead PhotoImpact and PhotoEditor.

  fly2hi 01:50 20 Aug 2004

This is probably not a solution to your particular problem but thought this was the best place to log some info on easyshare.
I downloaded easyshare V4 for the dx3700/camera dock and followed all the instructions re uninstall etc, disable anti-virus etc.
when running the zipped instal file it crashed with an error code "11x421x0x"
As usual the kodak site just sends you on a wild goose chase.
I tried reinstalling with Norton firewall open & anti-virus disabled and it worked. seems that if you disable the firewall, it still blocks the connection and prevents the download, but doesn't tell you. If you leave it running, it asks permission then gets on with it.
Note that the initial download is only the installer file (577kb). This needs to connect to get the full package (18MB)

  Zak 20:59 20 Aug 2004

Many thanks for your contribution fly2hi. I am still pursuing with Kodak via e-mail and phone. They do not seem to quick to respond and need chasing.
Here is a resume of what has happened so far:

On advice fro Kodak, I carried out the following with results as shown:

1. Searched for folder Catalog in C:\Program Files\Kodak\Kodak EasyShare Software\ - No such folder/file found

2. I uninstalled EasyShare Software via Add/Remove Programs

3. I ran the Kodak Clear Tool downloaded from your Web Site

4. I reinstalled EasyShare Software 3.3 with the computer in safe mode with no background applications running as per your instructions on your Web Site

5. When system rebooted, still in safe mode, following successful installation and error message again received: "mprapi.dll not found"

6. Again looked for catalog as in 1. above and folder/file still not present

7. Every time I double click on the Easy Share shortcut, the same error message appears.

8. Running the repair tool did not solve the problem

9. As requested I attach the system report as requested.

I made further contact with Kodak by phone and followed their suggestions and I have carried out the following:

1. Uninstalled Kodak EasyShare software via Add/Remove
2. Downloaded and ran the latest version 4 Kodak Clear software
3. Downloaded Microsoft Windows Installer 2.0
4. When installing the Microsoft Windows Installer 2.0, Windows gave me the
message that "the specified service already exists" and installation
5. Repeat installation of Kodak EasyShare software again resulted in the
original problem: "mprapi.dll not found" as detailed previously.

  Djohn 22:04 20 Aug 2004

I have the Kodak DX6340 with the easyshare dock. Installed the software for the camera/Dock and it worked fine first time in XP Pro. but after a format of the drive I couldn't get it to install again either from the CD or the Kodak site. My Brother-in-Law has the same camera with XP Home and it works fine.

The camera is superb but I thought I had wasted my money on the dock as unable to load the software it would not work. I was wrong, it will work without the software and better too. This is in XP though, not sure if you will get the same in 98se but worth trying.

Un-install the software then just connect the dock to your PC, Place the camera in the dock and turn on. The found new hardware wizard should now appear, follow the on-screen instructions to install. If you now look in your "My Computer" the camera should show up as a camera with the model number as well.

Using the Kodak software it just showed up as an extra drive. You can now click on the camera Icon to scroll through the photo's or use any photo editing software of your choice to up-load the photo's to the PC. [I use Adobe elements] The dock will still work as a means of uploading photo's and charging base as well.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?