Kingston Traveller II USB drive

  Howard's Way 15:52 18 May 2005

I have a Kingston Traveller II USB 512MB Drive and made it sucure with a password.

I then by mistake deleted the icon to bring up the password function. I am unable to get this back.

Then I thought to re-format the drive as I do not anything worthwhile on the drive. But under format I only have the 48MB not the secure part.

Anyone got any ideas how to fix this?

  Brian-336451 16:09 18 May 2005

Have you considered talking to Kingston - if you have the receipt and can prove it is YOUR data, they may be able to help.

Whilst not publicised I'd be surprised if there wasn't a way to release the rest.

Can you get them to give you the software again, there again many of these drives come with a tiny CD on which is the software and drivers for Win98.

If you've only deleted the icon, the program should still be installed on your computer. Have you tried to go to the installation directory and look for the exe program?

  VideoSentry 16:11 18 May 2005

Have you tried opening it using explorer to see if the Password thingy pops up?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Interview: Camille Walala on her giant 3D installation inspired by childhood funfair visits

Best iPad buying guide 2017

Où regarder le British Open 2017 ?