Kingston Data Traveler 2.0

  Spock1958 17:07 09 Aug 2007
Locked

I have a number of identical looking Data Traveler 1GB drives. One works perfectly on my Vista PC - it is labelled
DTI/1GB CN 060906 05360-302.AOOLF

I have a number of others labelled
DTI/1GB CN 030707 05360-311.AO1LF
These re not recognised on my PC, but will work on another PC with Windows XP installed.

I have tried contacting Kingston, but they cannot give me an suitable answer.

Any suggestions?

  Clapton is God 17:15 09 Aug 2007

I've also got a few Kingston Data Travellers.

In the past when I've first used a new Data Traveller on an XP PC, the found new hardware wizard pops up and does whatever if does!

Does Vista not have a similar wizard which somehow also needs to run?

  Spock1958 18:23 09 Aug 2007

Vista does have a Wizard, but it fails to find the driver. The irony is that an older model, identical other than a code on the case, works perfectly.

  Spock1958 19:37 09 Aug 2007

This doesn't work. I didn't expect it to as I have already copied files to it from an XP machine.

The suggestion to find the file on the original Vista disk didn't work either.

  Spock1958 21:30 09 Aug 2007

The files were unimportant so I formatted and overwrote them.

I have 3 USB ports, and the drives do not work in any of them.

  PP321 22:01 09 Aug 2007

Try this

Plug it into the troublesome computer, wait 20 seconds or so, then right click on my computer , then click manage, then click disk management , right mouse click on it if its there, choose "change drive letter and paths" then select a letter from "N" onwards then click change, then ok.

If the autorun doesnt appear, unplug and replug the device.

  Spock1958 11:47 10 Aug 2007

It doesn't appear in the list so cannot do this.

  PP321 18:43 10 Aug 2007

wow thats super spooky.


Sorry cant help you anymore then.

  Shiraj 17:38 27 Aug 2007

HI,
I had this issue too - but fixed it !

Try doing the folowing

1.Please wait longer (<20 sec) to see if the driver installation is slow on their system;

2. During device driver search, point to a location Windows\System32\DriverStore\FileRepository and enable "Include subfolders" in the Browse window.

If this fails, point to one of the subfolders within FileRepository:
FileRepository\usbstor.inf_...
FileRepository\disk.inf_...
FileRepository\volume.inf_...
FileRepository\wpdfs.inf_...

3. If FileRepository location(s) doesn't work, point to location Windows\System32\Spool\Drivers and enable "Include subfolders" in the Browse window.

4. Check Device Manager for incorrectly installed drivers for the DataTraveler; uninstall them and reinsert the drive.

If the DataTraveler starts working ok, reinsert and make sure the drive continues to work.

Rgds
Shiraj Juheer

  Spock1958 17:46 27 Aug 2007

It seems I had a fault with the card reader. After replacing the hardware the data Traveler worked fine. Why one Data Traveler worked and another didn't on a faulty card reader is another of those PC mysteries.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?