keys type wrong - help please

  dnjl 15:34 02 Nov 2008

On my laptop keyboard, some keys are typing the wrong things. i.e. the @ key types ", The " key teypes @, The £ types #, the # key types \.

There about 7 keys wrong in all.

Can anyone give me step-by-step instructions please?

  dnjl 15:34 02 Nov 2008

Forgot to say - I'm on Windows XP

  Technotiger 15:40 02 Nov 2008

Go to Start>Controol Panel>Regional and Language and set everything to English(UK)

  Clapton is God 15:41 02 Nov 2008

Control Panel; Date, Time, Language and Regional Options; Regional and language Options; click on the Languages tab, Details; Settings and ensure the Keyboard is set to United Kingdom.

  skidzy 15:44 02 Nov 2008

As above;

Missing @ Symbol

Normally this is a result of having a system set up for the US and not UK

Workaround solution: (1)

( Press and hold Shift + 2 ) should give = @

Changing your system keyboard configuration to uk in XP

Click Start / Control Panel / Switch to Classic View - click regional and language settings - looks like a globe

Select the region that you want then click on advanced - ensure there is a tick in the very bottom box that apples it to every user and default user setting.

Now goto the languages tab - select the region that you want - then click on the add button.

In the little box if you have another region in there as well - select it then click on the remove button.

Now click apply and then ok - then restart your pc - that should sort that out for you.

This is assuming you have Windows XP Home/Professional.

  [email protected] 16:02 02 Nov 2008

It's because the OS installation has the American k/b as an input device.
Pressing ALT + SHIFT will toggle your k/b to the usual UK QWERTY layout.
Start > settings > control panel > regional & language settings > language TAB > details >.
If the USA k/b is there, delete it by highlighting and clicking Remove.
If there is only the one k/b there, click Add and scroll to English (United Kindom) selection.
Now go ahead and delete the USA one.
I have English and French and toggle between the two by using the ALT + SHIFT method.

  dnjl 12:20 03 Nov 2008

Thanks for all your help. Now done & am happy

  Sea Urchin 12:42 03 Nov 2008

Mark as resolved?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

These beautiful, mesmerising & subtle GIFs celebrate 30 years of the artform

watchOS 4 review

Les meilleurs navigateurs internet 2017